Project

General

Profile

Bug #5584

Missing UUID parameters VMWare 5.5 (Foreman1.2)

Added by Kilian Desroches over 5 years ago. Updated over 5 years ago.

Status:
Duplicate
Priority:
Urgent
Category:
VM management
Target version:
-
Difficulty:
hard
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Hi,

I try to create a VM VMware ESX 5.5 with foreman and this is what I get:

RuntimeError
missing required parameter uuid
app/models/concerns/fog_extensions/vsphere/server.rb:36:in `scsi_controller_type='
app/models/compute_resources/foreman/model/vmware.rb:105:in `new_vm'
app/models/concerns/orchestration/compute.rb:21:in `compute_object'
app/views/hosts/_compute.html.erb:1:in `_app_views_hosts__compute_html_erb__197920929_70157843677960'
app/views/hosts/_unattended.html.erb:2:in `_app_views_hosts__unattended_html_erb___8886416_70157845865680'
app/views/hosts/_form.html.erb:91:in `_app_views_hosts__form_html_erb___2059520767_70157860439100'
app/helpers/layout_helper.rb:218:in `form_for'
app/views/hosts/_form.html.erb:7:in `_app_views_hosts__form_html_erb___2059520767_70157860439100'
app/models/taxonomy.rb:56:in `as_taxonomy'
app/models/concerns/foreman/thread_session.rb:143:in `as_location'
app/models/taxonomy.rb:55:in `as_taxonomy'
app/models/concerns/foreman/thread_session.rb:108:in `as_org'
app/models/taxonomy.rb:54:in `as_taxonomy'
app/views/hosts/_form.html.erb:5:in `_app_views_hosts__form_html_erb___2059520767_70157860439100'
app/views/hosts/new.html.erb:7:in `_app_views_hosts_new_html_erb___565157055_70157842913420'
app/controllers/application_controller.rb:287:in `process_error'
app/controllers/hosts_controller.rb:94:in `create'
app/models/concerns/foreman/thread_session.rb:33:in `clear_thread'
lib/middleware/catch_json_parse_errors.rb:9:in `call'

Can you help me?

Thanks
Kilian


Related issues

Is duplicate of Foreman - Bug #4590: Can't create new VMware virtual machine : missing required parameter uuidClosed2014-03-07

History

#1 Updated by Dominic Cleal over 5 years ago

  • Is duplicate of Bug #4590: Can't create new VMware virtual machine : missing required parameter uuid added

#2 Updated by Dominic Cleal over 5 years ago

  • Status changed from New to Duplicate

Please see issue #4590, particularly the last couple of comments as there is a patch you can use (will be in our next release).

Also available in: Atom PDF