Project

General

Profile

Bug #5762

Multiple matchers on smart variable

Added by Paula Vaughan over 5 years ago. Updated over 5 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Smart Variables
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

I'm trying to set up multiple matchers on a smart variable. When I do so, I receive the following error...

PGError: ERROR: value too long for type character varying(255) : INSERT INTO "audits" ("action", "associated_id", "associated_name", "associated_type", "auditable_id", "auditable_name", "auditable_type", "audited_changes", "comment", "created_at", "remote_address", "user_id", "user_type", "username", "version") VALUES ($1, $2, $3, $4, $5, $6, $7, $8, $9, $10, $11, $12, $13, $14, $15) RETURNING "id"

The full trace is...
ActiveRecord::StatementInvalid
PGError: ERROR: value too long for type character varying(255) : INSERT INTO "audits" ("action", "associated_id", "associated_name", "associated_type", "auditable_id", "auditable_name", "auditable_type", "audited_changes", "comment", "created_at", "remote_address", "user_id", "user_type", "username", "version") VALUES ($1, $2, $3, $4, $5, $6, $7, $8, $9, $10, $11, $12, $13, $14, $15) RETURNING "id"
app/controllers/puppetclasses_controller.rb:32:in `update'
app/models/concerns/foreman/thread_session.rb:33:in `clear_thread'
lib/middleware/catch_json_parse_errors.rb:9:in `call'

The input was as follows:
The value in the "Order" field was
os,fqdn
and the value in the "Match" field was
os=stupid,fqdn=dummy

From the way I read the documentation for implementing multiple matchers, this should have worked. Am I perhaps misreading the documentation?


Related issues

Is duplicate of Foreman - Bug #5671: Stack trace due to audit table field being too shortClosed2014-05-12

History

#1 Updated by Dominic Cleal over 5 years ago

  • Is duplicate of Bug #5671: Stack trace due to audit table field being too short added

#2 Updated by Dominic Cleal over 5 years ago

  • Status changed from New to Duplicate

This looks like the same issue as #5671, except I think it's the value of the matcher that's causing the problem rather than the matcher itself. We've got a fix prepared for Foreman 1.5.1 via that bug.

Also available in: Atom PDF