Project

General

Profile

Bug #6435

Search on filter page for filtering resources raises NetworkError 404 not found

Added by Stephen Benjamin almost 8 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Normal
Category:
Web UI
Target version:
Difficulty:
trivial
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1111531
Description of problem:
I was trying add permissions to selected role. So I choose "View_content_views" from resource type "Content View" and try to search the resources and UI throws 404 in firebug. Please see the screenshot.

Production.log has following entries:

ActionController::RoutingError (No route matches [GET] "/katello/content_views/auto_complete_search"):
/usr/lib/ruby/gems/1.8/gems/passenger-4.0.18/lib/phusion_passenger/rack/thread_handler_extension.rb:77:in `process_request'
/usr/lib/ruby/gems/1.8/gems/passenger-4.0.18/lib/phusion_passenger/request_handler/thread_handler.rb:140:in `accept_and_process_next_request'
/usr/lib/ruby/gems/1.8/gems/passenger-4.0.18/lib/phusion_passenger/request_handler/thread_handler.rb:108:in `main_loop'
/usr/lib/ruby/gems/1.8/gems/passenger-4.0.18/lib/phusion_passenger/request_handler.rb:441:in `block (3 levels) in start_threads'

ActionController::RoutingError (No route matches [GET] "/katello/content_views/auto_complete_search"):
/usr/lib/ruby/gems/1.8/gems/passenger-4.0.18/lib/phusion_passenger/rack/thread_handler_extension.rb:77:in `process_request'
/usr/lib/ruby/gems/1.8/gems/passenger-4.0.18/lib/phusion_passenger/request_handler/thread_handler.rb:140:in `accept_and_process_next_request'
/usr/lib/ruby/gems/1.8/gems/passenger-4.0.18/lib/phusion_passenger/request_handler/thread_handler.rb:108:in `main_loop'
/usr/lib/ruby/gems/1.8/gems/passenger-4.0.18/lib/phusion_passenger/request_handler.rb:441:in `block (3 levels) in start_threads'

Version-Release number of selected component (if applicable):
sat6 beta snap10

How reproducible:
always

Steps to Reproduce:
1. create a role
2. add permissions, choose 'content view' as resource type
3. add "View_content_views" permission
4. uncheck "Unlimited" check box
5. in search box, just click

Actual results:
Network error 404 not found

Expected results:
Resource should be available and no 404 should be raised

Additional info:


Related issues

Related to Katello - Tracker #4638: Scoped Search ConversionResolved2014-03-12

Is duplicate of Katello - Bug #6488: roles: auto search should be enabled for all katello related resource types.Closed2014-07-03

History

#1 Updated by Eric Helms almost 8 years ago

  • Category set to Web UI
  • Status changed from New to Assigned
  • Assignee set to Stephen Benjamin
  • Target version set to 48
  • Difficulty set to trivial
  • Triaged set to Yes

#2 Updated by Stephen Benjamin almost 8 years ago

  • Status changed from Assigned to Rejected

Foreman's Filters make queries to model_path/auto_complete_search. This URL is generated here:

https://github.com/theforeman/foreman/blob/develop/app/helpers/filters_helper.rb

For activation_keys and some other Katello models, there is no route in config/routes.rb (that all happens in bastion's routes.js) -- so no search URL is generated.

Content views do have a route defined in config/routes.rb, so filters_helper generates the /katello/content_views/auto_complete_search path -- which doesn't actually exist, thus the error in Firebug.

Foreman could validate the actual auto_complete_search path is valid, but Rails.application.routes.recognize_path doesn't seem to work with engines.

This will be fixed on the Katello side once #4638 is resolved and the models all have auto_complete_search anyway.

#3 Updated by Stephen Benjamin almost 8 years ago

#4 Updated by Stephen Benjamin almost 8 years ago

  • Status changed from Rejected to Assigned

Actually I'll just take this up as implementing auto completion...

#5 Updated by Stephen Benjamin almost 8 years ago

  • Status changed from Assigned to Ready For Testing

#6 Updated by Stephen Benjamin almost 8 years ago

  • Related to Bug #6488: roles: auto search should be enabled for all katello related resource types. added

#7 Updated by Stephen Benjamin almost 8 years ago

  • Related to deleted (Bug #6488: roles: auto search should be enabled for all katello related resource types.)

#8 Updated by Stephen Benjamin almost 8 years ago

  • Is duplicate of Bug #6488: roles: auto search should be enabled for all katello related resource types. added

#9 Updated by Stephen Benjamin almost 8 years ago

  • Status changed from Ready For Testing to Duplicate

#10 Updated by Eric Helms almost 8 years ago

  • Legacy Backlogs Release (now unused) set to 13

#11 Updated by Eric Helms about 7 years ago

  • Legacy Backlogs Release (now unused) deleted (13)

#12 Updated by Eric Helms almost 6 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF