Project

General

Profile

Bug #7255

unable to delete puppet class

Added by Neeraj Harikrishnan about 6 years ago. Updated about 6 years ago.

Status:
Duplicate
Priority:
Urgent
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

I get a error while I try to delete puppet class from foreman interface.

ActiveRecord::StatementInvalid
Mysql2::Error: Cannot delete or update a parent row: a foreign key constraint fails (`foreman`.`environment_classes`, CONSTRAINT `environment_classes_puppetclass_id_fk` FOREIGN KEY (`puppetclass_id`) REFERENCES `puppetclasses` (`id`)): DELETE FROM `puppetclasses` WHERE `puppetclasses`.`id` = 86
app/controllers/puppetclasses_controller.rb:40:in `destroy'
app/models/concerns/foreman/thread_session.rb:33:in `clear_thread'
lib/middleware/catch_json_parse_errors.rb:9:in `call'


Related issues

Is duplicate of Foreman - Bug #4379: Foreign key constraint error on deleting a classResolved2014-02-18

History

#1 Updated by Neeraj Harikrishnan about 6 years ago

Please close I found the original bug. Sorry

#2 Updated by Anonymous about 6 years ago

Could you please give us the number of that bug, so we can set this report as a duplicate?

#4 Updated by Anonymous about 6 years ago

  • Is duplicate of Bug #4379: Foreign key constraint error on deleting a class added

#5 Updated by Anonymous about 6 years ago

  • Status changed from New to Duplicate

thanks!

Also available in: Atom PDF