Project

General

Profile

Bug #7899

CentOS: foreman seems to depend on centos-release-SCL, not the packages it actually needs

Added by Adam Bishop almost 5 years ago. Updated almost 5 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

I've just attempted to install foreman on CentOS 7, however the installer is logging:

 Execution of '/usr/bin/yum -d 0 -e 0 -y list centos-release-SCL' returned 1: Error: No matching Packages to list
 /Stage[main]/Foreman::Install::Repos::Extra/Package[centos-release-SCL]/ensure: change from absent to present failed: Execution of '/usr/bin/yum -d 0 -e 0 -y list centos-release-SCL' returned 1: Error: No matching Packages to list

centos-release-SCL does not currently exist for CentOS (and will likely not exist for the foreseeable future) - the individual packages that foreman needs are available from http://projects.theforeman.org/projects/foreman/issues/new

Could this dependency be removed and replaced with the individual release files, i.e.:
yum install https://www.softwarecollections.org/en/scls/rhscl/ruby193/epel-7-x86_64/download/rhscl-ruby193-epel-7-x86_64.noarch.rpm


Related issues

Is duplicate of Packaging - Refactor #7234: SCL 1.1 builds needed for EL rebuilds (CentOS, SL)Closed2014-08-22

History

#2 Updated by Dominic Cleal almost 5 years ago

  • Is duplicate of Refactor #7234: SCL 1.1 builds needed for EL rebuilds (CentOS, SL) added

#3 Updated by Dominic Cleal almost 5 years ago

  • Status changed from New to Duplicate

Thanks for the report. 1.6 doesn't officially support CentOS 7 at the moment for this reason, but we've been working on it in #7234. Nightlies should now work.

Also available in: Atom PDF