Project

General

Profile

Feature #8051

Repo-Sync: Make execution date/time changeable

Added by Andreas Pfaffeneder over 4 years ago. Updated 7 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Web UI
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Katello 2/Foreman 1.6-Combo on Centos 6.5/x86_64, Firefox 33.0, Win8/64

Steps to reproduce:
1.) Add new sync plan.
2.) Want to edit execution time and not lose association of products<->sync-plan

Result:
Cant edit execution date/time

Expected:
Can edit execution date/time

History

#1 Updated by Eric Helms over 4 years ago

  • Tracker changed from Feature to Bug

#2 Updated by Eric Helms over 4 years ago

  • Tracker changed from Bug to Feature
  • Status changed from New to Need more information
  • Triaged changed from No to Yes

Sounds like what you are requesting is a way to set a non-interval sync plan for sometime in the future and then update the planned sync time manually?

#3 Updated by Andreas Pfaffeneder over 4 years ago

I do this:

Create a new sync-plan with daily 10:00 interval for example.
Later want to move the sync from 10:00 to 22:00 because I made a mistake.

Currently one only can edit the properties: Name, Description and Interval but not the actual start time. But that'd should be possible.

#4 Updated by Jorick Astrego about 4 years ago

Just ran into the same issue today, there are lots of reasons to modify the sync plan later on. Sometimes it's to tune the load, other times to sync before a patching round.

Sometimes you just want to change the time/date because you didn't choose wisely ....

#5 Updated by Eric Helms over 3 years ago

  • Status changed from Need more information to Resolved
  • Legacy Backlogs Release (now unused) set to 70

This should be do-able in the current release. As well, the Katello 2.4 release will include the ability to execute a sync plan manually.

#6 Updated by Eric Helms over 3 years ago

  • Category set to Web UI

Also available in: Atom PDF