Project

General

Profile

Bug #9271

500 ISE: on searching image from new container page

Added by Daniel Lobato Garcia over 7 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1190088
Description of problem:

I was trying to create new conatiner but when I tried to search the image from new container page, firebug raises error:

---
"NetworkError: 500 Internal Server Error - https://hp-ml370g5-01.rhts.eng.bos.redhat.com/image_search/2/auto_complete_repository_name?search=bus&registry_id="
---

production.log: ===============

Processing by ImageSearchController#auto_complete_image_tag as JSON
Parameters: {"search"=>"busybox", "registry_id"=>"", "id"=>"2"}
String does not start with the prefix 'encrypted-', so ForemanDocker::Docker test was not decrypted
Completed 200 OK in 197ms (Views: 0.7ms | ActiveRecord: 5.9ms)
Rendered common/500.html.erb (100.5ms)
Completed 500 Internal Server Error in 2653ms (Views: 1155.9ms | ActiveRecord: 93.4ms)

Version-Release number of selected component (if applicable):

  • apr-util-ldap-1.3.9-3.el6_0.1.x86_64
  • candlepin-0.9.41-1.el6.noarch
  • candlepin-common-1.0.20-1.el6.noarch
  • candlepin-scl-1-5.el6_4.noarch
  • candlepin-scl-quartz-2.1.5-5.el6_4.noarch
  • candlepin-scl-rhino-1.7R3-1.el6_4.noarch
  • candlepin-scl-runtime-1-5.el6_4.noarch
  • candlepin-selinux-0.9.41-1.el6.noarch
  • candlepin-tomcat6-0.9.41-1.el6.noarch
  • elasticsearch-0.90.10-7.el6.noarch
  • foreman-1.7.2.3-1.el6_6sat.noarch
  • foreman-compute-1.7.2.3-1.el6_6sat.noarch
  • foreman-gce-1.7.2.3-1.el6_6sat.noarch
  • foreman-libvirt-1.7.2.3-1.el6_6sat.noarch
  • foreman-ovirt-1.7.2.3-1.el6_6sat.noarch
  • foreman-postgresql-1.7.2.3-1.el6_6sat.noarch
  • foreman-proxy-1.7.2.1-1.el6_6sat.noarch
  • foreman-selinux-1.7.2.8-1.el6_6sat.noarch
  • foreman-vmware-1.7.2.3-1.el6_6sat.noarch
  • katello-2.2.0.2-1.el6_6sat.noarch
  • katello-certs-tools-2.2.1-1.el6_6sat.noarch
  • katello-common-2.2.0.2-1.el6_6sat.noarch
  • katello-default-ca-1.0-1.noarch
  • katello-installer-2.2.0.3-1.el6_6sat.noarch
  • katello-installer-base-2.2.0.3-1.el6_6sat.noarch
  • katello-server-ca-1.0-1.noarch
  • openldap-2.4.39-8.el6.x86_64
  • openldap-devel-2.4.39-8.el6.x86_64
  • pulp-docker-plugins-0.2.1-0.2.beta.el6_6sat.noarch
  • pulp-katello-0.3-4.el6sat.noarch
  • pulp-nodes-common-2.5.0-0.7.beta.el6_6sat.noarch
  • pulp-nodes-parent-2.5.0-0.7.beta.el6_6sat.noarch
  • pulp-puppet-plugins-2.5.0-0.7.beta.el6sat.noarch
  • pulp-puppet-tools-2.5.0-0.7.beta.el6sat.noarch
  • pulp-rpm-plugins-2.5.0-0.7.beta.el6_6sat.noarch
  • pulp-selinux-2.5.0-0.7.beta.el6_6sat.noarch
  • pulp-server-2.5.0-0.7.beta.el6_6sat.noarch
  • python-ldap-2.3.10-1.el6.x86_64
  • ruby193-rubygem-ldap_fluff-0.3.2-1.el6_6sat.noarch
  • ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
  • ruby193-rubygem-runcible-1.3.0-1.el6_6sat.noarch
  • rubygem-hammer_cli-0.1.4.3-1.el6_6sat.noarch
  • rubygem-hammer_cli_foreman-0.1.4.3-1.el6_6sat.noarch
  • rubygem-hammer_cli_foreman_bootdisk-0.1.2.4-1.el6_6sat.noarch
  • rubygem-hammer_cli_foreman_tasks-0.0.3.1-1.el6_6sat.noarch
  • rubygem-hammer_cli_gutterball-0.0.1.1-1.el6_6sat.noarch
  • rubygem-hammer_cli_import-0.10.6-1.el6sat.noarch
  • rubygem-hammer_cli_katello-0.0.7.1-1.el6_6sat.noarch

How reproducible:
always

Steps to Reproduce:
1. search the image from new container page
2.
3.

Actual results:
---
"NetworkError: 500 Internal Server Error - https://hp-ml370g5-01.rhts.eng.bos.redhat.com/image_search/2/auto_complete_repository_name?search=bus&registry_id="
---

Expected results:
there shouldn't be any error on searching image from container page

Additional info:

Associated revisions

Revision 70dd1b81 (diff)
Added by Dmitri Dolguikh over 7 years ago

fixes #9271: user is now informed about http connection errors when using search in the new container wizard.

Revision 70dd1b81 (diff)
Added by Dmitri Dolguikh over 7 years ago

fixes #9271: user is now informed about http connection errors when using search in the new container wizard.

History

#1 Updated by Daniel Lobato Garcia over 7 years ago

  • Assignee deleted (Daniel Lobato Garcia)

#2 Updated by Dmitri Dolguikh over 7 years ago

  • Status changed from New to Need more information

Can't reproduce with the latest code from foreman and foreman-docker (as of 18/02).

#3 Updated by The Foreman Bot over 7 years ago

  • Status changed from Need more information to Ready For Testing
  • Pull request https://github.com/theforeman/foreman-docker/pull/87 added
  • Pull request deleted ()

#4 Updated by Anonymous over 7 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF