Project

General

Profile

Bug #9534

Slow UI (>20seconds to load page) Composite Content-view -> Adding Content Views

Added by Walden Raines over 4 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Web UI
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1120765
Description of problem:
Adding content-views to composite content-view is slow. Every time I attempt to add an individual content-view to a composite content-view the UI reloads the entire list of content-views available to be added. In my environment with 100 content-views this results in a >20s load time on the UI.

Version-Release number of selected component (if applicable):
Sat 6.0.3 Beta
Build: Snap11-Compose3
RHEL 6.5 2.6.32-431.20.3
katello-1.5.0-26.el6sat.noarch
foreman-1.6.0.21-1.el6sat.noarch
candlepin-0.9.19-1.el6_5.noarch
pulp-server-2.4.0-0.23.beta.el6sat.noarch
puppet-3.6.2-1.el6sat.noarch

How reproducible:
Always

Steps to Reproduce:
1. Sat 6.0.3 with manifest uploaded, content synced, custom content synced, and content views published/promoted
2. Create Composite Content-view and navigate to Content-Views Tab -> Add (Wait for page to load) with enough content-views this page will take longer than 20 seconds to load.

Actual results:
The page takes more than 20 seconds to load.

Expected results:
I would expect the page load to take less than 20 seconds.

Additional info:
A grep against the captured foreman/production log shows:
  1. grep "CACHE" production.log -c
    707
  2. grep "SELECT" production.log -c
    1860
  3. grep "Completed" production.log
    Completed 200 OK in 23781ms (Views: 22595.7ms | ActiveRecord: 681.8ms)

^ Greater than 20 seconds to load the page and a large number of queries to load the page as well.

This problem becomes more noticeable as an individual is adding individual content-views as the page reloads each time "+ Add Content Views" is pressed

Associated revisions

Revision 0603abca (diff)
Added by Walden Raines over 4 years ago

Fixes #9534: fix N+1 queries on content view index.

The content views were slow to load in the composite list/add
pages because of several N+1 queries. This commit fixes the N+1s
on content view index.

http://projects.theforeman.org/issues/9534
https://bugzilla.redhat.com/show_bug.cgi?id=1120765

Revision f0802f99
Added by Walden Raines over 4 years ago

Merge pull request #5047 from waldenraines/9534

Fixes #9534: fix N+1 queries on content view index.

History

#1 Updated by Eric Helms over 4 years ago

  • Target version set to 67
  • Legacy Backlogs Release (now unused) set to 23
  • Triaged changed from No to Yes

#2 Updated by The Foreman Bot over 4 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/5047 added
  • Pull request deleted ()

#3 Updated by Walden Raines over 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF