Bug #17587

Upgrade autoprefixer gem

Added by Tomer Brisker 7 months ago. Updated 6 months ago.

Status:Closed
Priority:Normal
Assigned To:Tomer Brisker
Category:Packaging
Target version:Team Daniel - iteration 6
Difficulty: Bugzilla link:
Found in release: Pull request:https://github.com/theforeman/foreman/pull/4086
Story points-
Velocity based estimate-
Release1.15.0Release relationshipAuto

Description

The autoprefixer-rails gem is outdated, leading to some annoying deprecation messages such as:
DEPRECATION WARNING: You are using the a deprecated processor interface #<Proc:0x0000000c9a3f60@/home/tbrisker/.rvm/gems/ruby-2.0.0-p648@foreman_gemset/gems/autoprefixer-rails-5.2.1.3/lib/autoprefixer-rails/sprockets.rb:25>.
Newer versions also remove default support for legacy browsers we don't support anyways (IE <10).

Associated revisions

Revision 68d1bc89
Added by Tomer Brisker 6 months ago

Fixes #17587 - remove autoprefixer gem

Revision 2e3319e5
Added by Dominic Cleal 6 months ago

refs #17587 - remove explicit autoprefixer dep

History

#1 Updated by The Foreman Bot 7 months ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/4086 added

#2 Updated by Daniel Lobato Garcia 6 months ago

  • Target version set to Team Daniel - iteration 6

#3 Updated by Anonymous 6 months ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#4 Updated by Dominic Cleal 6 months ago

  • Release set to 1.15.0

Also available in: Atom PDF