Project

General

Profile

Bug #10019

Compute Profile Memory options different for selected language?

Added by Aditya Gupta over 4 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Compute resources
Target version:
Difficulty:
medium
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Hi,

When we try to create new compute profile in foreman GUI, it displays different memory option in drop down list on the basis of language selected in profile.

I checked for Deutsch and English.

It should give same options for all display.

Thanks
Aditya

Compute profile_ EN.png View Compute profile_ EN.png 26 KB Compute Profile for English Language. Aditya Gupta, 04/09/2015 03:37 AM
Rechnerprofil_ DE.png View Rechnerprofil_ DE.png 29.7 KB Compute Profile for Deutche Language. Aditya Gupta, 04/09/2015 03:37 AM
Compute%20profile %20en Rechnerprofil %20de

Related issues

Related to Foreman - Feature #7230: Upgrade Ruby on Rails to 4.1Closed2014-08-22

History

#1 Updated by Dominic Cleal over 4 years ago

  • Category set to Compute resources
  • Status changed from New to Need more information

Which type of compute resource are you using? (Libvirt, VMware etc)

What different memory options do you see? Screenshots would be great if could attach them.

#2 Updated by Aditya Gupta over 4 years ago

Hello Dominic,

Thanks for response.

We are using Libvirt compute resource.

Please find attached screenshots for English & Deutsche language.

You can see different options in drop down menu.

Thanks,
Aditya

#3 Updated by Dominic Cleal over 4 years ago

#4 Updated by Dominic Cleal over 4 years ago

  • Status changed from Need more information to New
  • Priority changed from High to Normal

How strange! I found the cause though, it comes from the localisation files that we include for Rails. We can't just change ours else they'll revert, but this has been fixed in the upstream project and will be fixed when we move to Rails 4.

https://github.com/svenfuchs/rails-i18n/commit/c757651a692f1f632a1da25d061bf4d53042ebf3

#5 Updated by Dominic Cleal almost 4 years ago

#6 Updated by Dominic Cleal almost 4 years ago

#7 Updated by Dominic Cleal almost 4 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100
  • Legacy Backlogs Release (now unused) set to 71

This should be fixed with the update to Rails 4 and a newer rails-i18n gem.

Also available in: Atom PDF