Project

General

Profile

Bug #10199

Docker Compute Resource - New Image: Submit button should be disabled upon click

Added by Bryan Kearney about 7 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Normal
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1190183
Description of problem:
When creating a New Image within a Docker compute resource, the submit button does not disable after initial submit. An errant/accidental double-click ends up returning an error that the Image "has already been taken"

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Create a docker compute resource
2. Infrastructure > Compute Resources > $docker_cr > New Image
3. begin filling out the form
4. "Accidentally" click the Submit button twice.

Actual results:
Two submissions for this data are inadvertently submitted.
User gets an error that the image "has already been taken" (because it has, with the first click) but gets no real indication that the first one was ever functional.

Expected results:
Disable the button upon submit. I guess we could re-enable it upon failed create, so user can fix any errors that resulted (though I would think validation before submit would catch most of this).

Additional info:

Associated revisions

Revision a02da228 (diff)
Added by Daniel Lobato Garcia over 6 years ago

Fixes #10199 - Disable image capabilities under compute resource

Docker container images are not created this way, and its just confusing
to users when they see this tab.

Revision a02da228 (diff)
Added by Daniel Lobato Garcia over 6 years ago

Fixes #10199 - Disable image capabilities under compute resource

Docker container images are not created this way, and its just confusing
to users when they see this tab.

History

#1 Updated by Daniel Lobato Garcia about 7 years ago

I think it should be disabled entirely. We're misleading people into thinking they can create images through it somehow.

#2 Updated by The Foreman Bot over 6 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman-docker/pull/152 added

#3 Updated by Daniel Lobato Garcia over 6 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF