Project

General

Profile

Bug #10309

Bulk Actions -> Errata page does not load

Added by Walden Raines about 7 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Web UI
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1216195
Description of problem:
Bulk Actions -> Errata page does not load

Version-Release number of selected component (if applicable):
Satellite-6.1.0-RHEL-6-20150424.0

How reproducible:
Always

Steps to Reproduce:
1. Navigate to Hosts -> Host Collections -> Select a host collection
2. Go to Collection Actions tab -> click on Errata Installation

Actual results:
The UI does not load and I saw the following error in foreman/production.log

2015-04-28 13:49:23 [E] NameError: uninitialized constant Katello::SystemsBulkAction
/opt/rh/ruby193/root/usr/share/gems/gems/foreman_hooks-0.3.7/lib/foreman_hooks.rb:83:in `load_missing_constant_with_hooks'
/opt/rh/ruby193/root/usr/share/gems/gems/rake-0.9.2.2/lib/rake/ext/module.rb:36:in `const_missing'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/inflector/methods.rb:230:in `block in constantize'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/inflector/methods.rb:229:in `each'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/inflector/methods.rb:229:in `constantize'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/core_ext/string/inflections.rb:54:in `constantize'
/opt/rh/ruby193/root/usr/share/gems/gems/katello-2.2.0.37/app/controllers/katello/api/v2/api_controller.rb:51:in `rescue in resource_class'
/opt/rh/ruby193/root/usr/share/gems/gems/katello-2.2.0.37/app/controllers/katello/api/v2/api_controller.rb:49:in `resource_class'
/opt/rh/ruby193/root/usr/share/gems/gems/katello-2.2.0.37/app/controllers/katello/api/v2/api_controller.rb:89:in `scoped_search'

Expected results:
The UI loads

Additional info:

Associated revisions

Revision ecbb51bc (diff)
Added by Walden Raines about 7 years ago

Fixes #10309: prevent ISE on CH bulk actions errata BZ1216195.

We were calling the resource class method in cases where it was
not appropriate because fetch() calls the default before checking
if the value exists. This commit sets the default after attempting
the fetch first.

http://projects.theforeman.org/issues/10309
https://bugzilla.redhat.com/show_bug.cgi?id=1216195

Revision 23e954a6
Added by Walden Raines about 7 years ago

Merge pull request #5199 from waldenraines/10309

Fixes #10309: prevent ISE on CH bulk actions errata BZ1216195.

History

#1 Updated by The Foreman Bot about 7 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/5199 added
  • Pull request deleted ()

#2 Updated by Justin Sherrill about 7 years ago

  • Legacy Backlogs Release (now unused) set to 51

#3 Updated by Eric Helms about 7 years ago

  • Triaged changed from No to Yes

#4 Updated by Walden Raines about 7 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF