Project

General

Profile

Bug #11160

The Satellite 6.0 installation is failing with error '/var/lib/candlepin/cpinit_done returned 8 instead of one of [0]'

Added by Bryan Kearney over 5 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
High
Assignee:
-
Category:
-
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1236541
Description of problem:

The Satellite 6.0 installation is failing with error '/var/lib/candlepin/cpinit_done returned 8 instead of one of [0]' even when all of below things are correct,

1. The system has umask 0022
2. The /etc/hosts file has correct localhost entries as below,

127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4
::1 localhost localhost.localdomain localhost6 localhost6.localdomain6

3. There is no firewall or proxy set which may block connections to localhost on port 8080.
4. The system has java 1.7 installed only.
5. There is no http_proxy environment variable set.

Version-Release number of selected component (if applicable):

Satellite 6.0.8

How reproducible:

Can see one case where even when having all things at correct places installation fails.

Steps to Reproduce:
1. Have all things correct on Satellite.
2. Run katello-installer
3. Fails with generic error,

'/var/lib/candlepin/cpinit_done returned 8 instead of one of [0]'

Actual results:

Fails with generic error.

Expected results:

Should not fails and installation should be successful.

Additional info:

Associated revisions

Revision b038d13c (diff)
Added by Bryan Kearney over 5 years ago

Fixes #11160 : Increase the number of times the scripts attempts to call cpinit before failing.

The prevailing thought is that this is due to lack of entropy on vms. If that is trye, all that can be done
is wait longer. This bumps up the script to attempt to connect 40 times, waiting 20 seconds between attempts.
This should give 800 seconds for the machine to get entropy

Revision 43b7900d
Added by Bryan Kearney over 5 years ago

Merge pull request #23 from bkearney/bkearney/11160

Fixes #11160 : Increase the number of times the scripts attempts to c…

History

#1 Updated by The Foreman Bot over 5 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello-installer/pull/242 added
  • Pull request deleted ()

#2 Updated by Eric Helms over 5 years ago

  • Legacy Backlogs Release (now unused) set to 70
  • Triaged changed from No to Yes

#3 Updated by Justin Sherrill about 5 years ago

  • Legacy Backlogs Release (now unused) changed from 70 to 86

#4 Updated by Bryan Kearney about 5 years ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF