Project

General

Profile

Bug #1143

Searching for hosts with parameters is broken.

Added by Bash Shell almost 11 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Search
Target version:
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

How to reproduce:

1> Create 2 hosts
2> Add a parameter to ONE of the above hosts: "Param-name = param1 and Param-value = val1"
3> Search on the web interface for: "params.param1 ~ val1"
4> Expected results: One host should be returned.
5> Actual results: Hosts not having this parameter are returned.

Associated revisions

Revision 7c9f112e (diff)
Added by Amos Benari over 9 years ago

fixes #1143 Searching for hosts with parameters is broken.

History

#1 Updated by Bash Shell almost 11 years ago

Note that searching with "=" instead of "~" works fine:

"params.param1 = val1"

#2 Updated by Ohad Levy almost 11 years ago

  • Assignee set to Amos Benari

#3 Updated by Bash Shell almost 11 years ago

Looks like in the latest develop, searching for anything returns results:
Like:

"params.noexist = noexist"

returns all hosts.

#4 Updated by Ohad Levy over 10 years ago

@amos bump?

#5 Updated by Greg Sutcliffe over 9 years ago

  • Target version set to Bug scrub

#6 Updated by Ohad Levy over 9 years ago

  • Category set to Search

#7 Updated by Amos Benari over 9 years ago

  • Status changed from New to Resolved

#8 Updated by Ohad Levy over 9 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF