Project

General

Profile

Actions

Bug #11679

closed

Runtime Error null when deleting component content views

Added by Jason Frisvold over 8 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
Normal
Category:
-
Target version:
Difficulty:
Triaged:
Fixed in Releases:
Found in Releases:

Description

I'm in the process of deleting a bunch of old content views no longer in use. The process I've used is to reassociate the content host with a new view, delete the view from it's associated environments, and then remove the view. While in the process of removing the view, the task stops with an error. This seems to happen 1-2 times per view. The error in the gui is "Runtime Error null at org.candlepin.model.AbstractHibernateCurator.delete:326"

If I click "resume" the task will continue along and eventually either hit the same error again, or complete the task.

The foreman production log shows the following trace :

2015-09-03 10:19:29 [foreman-tasks/action] [E] Runtime Error null at org.candlepin.model.AbstractHibernateCurator.delete:326 (Katello::Errors::CandlepinError) | /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.3.0/app/lib/actions/middleware/propagate_candlepin_errors.rb:21:in `rescue in propagate_candlepin_errors' | /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.3.0/app/lib/actions/middleware/propagate_candlepin_errors.rb:19:in `propagate_candlepin_errors' | /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.3.0/app/lib/actions/middleware/propagate_candlepin_errors.rb:9:in `run' | /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.8.5/lib/dynflow/middleware/stack.rb:22:in `call' | /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.8.5/lib/dynflow/middleware/stack.rb:26:in `pass' | /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.8.5/lib/dynflow/middleware.rb:16:in `pass' | /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.3.0/app/lib/actions/middleware/remote_action.rb:16:in `block in run' | /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.3.0/app/lib/actions/middleware/remote_action.rb:46:in `block (2 levels) in as_remote_user' | /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.3.0/app/lib/katello/util/thread_session.rb:72:in `pulp_config' | /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.3.0/app/lib/actions/middleware/remote_action.rb:32:in `as_pulp_user' | /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.3.0/app/lib/actions/middleware/remote_action.rb:45:in `block in as_remote_user' | /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.3.0/app/lib/katello/util/thread_session.rb:79:in `cp_config' | /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.3.0/app/lib/actions/middleware/remote_action.rb:27:in `as_cp_user' | /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.3.0/app/lib/actions/middleware/remote_action.rb:44:in `as_remote_user' | /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.3.0/app/lib/actions/middleware/remote_action.rb:16:in `run' | /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.8.5/lib/dynflow/middleware/stack.rb:22:in `call' | /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.8.5/lib/dynflow/middleware/stack.rb:26:in `pass' | /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.8.5/lib/dynflow/middleware.rb:16:in `pass' | /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.8.5/lib/dynflow/action/progress.rb:30:in `with_progress_calculation' | /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.8.5/lib/dynflow/action/progress.rb:16:in `run' | /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.8.5/lib/dynflow/middleware/stack.rb:22:in `call' | /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.8.5/lib/dynflow/middleware/stack.rb:26:in `pass' | /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.8.5/lib/dynflow/middleware.rb:16:in `pass' | /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.3.0/app/lib/actions/middleware/keep_locale.rb:11:in `block in run' | /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.3.0/app/lib/actions/middleware/keep_locale.rb:22:in `with_locale' | /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.3.0/app/lib/actions/middleware/keep_locale.rb:11:in `run' | /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.8.5/lib/dynflow/middleware/stack.rb:22:in `call' | /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.8.5/lib/dynflow/middleware/world.rb:30:in `execute' | /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.8.5/lib/dynflow/action.rb:505:in `block (2 levels) in execute_run' | /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.8.5/lib/dynflow/action.rb:504:in `catch' | /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.8.5/lib/dynflow/action.rb:504:in `block in execute_run' | /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.8.5/lib/dynflow/action.rb:419:in `call' | /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.8.5/lib/dynflow/action.rb:419:in `block in with_error_handling' | /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.8.5/lib/dynflow/action.rb:419:in `catch' | /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.8.5/lib/dynflow/action.rb:419:in `with_error_handling' | /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.8.5/lib/dynflow/action.rb:499:in `execute_run' | /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.8.5/lib/dynflow/action.rb:260:in `execute' | /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.8.5/lib/dynflow/execution_plan/steps/abstract_flow_step.rb:9:in `block (2 levels) in execute' | /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.8.5/lib/dynflow/execution_plan/steps/abstract.rb:155:in `call' | /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.8.5/lib/dynflow/execution_plan/steps/abstract.rb:155:in `with_meta_calculation' | /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.8.5/lib/dynflow/execution_plan/steps/abstract_flow_step.rb:8:in `block in execute' | /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.8.5/lib/dynflow/execution_plan/steps/abstract_flow_step.rb:22:in `open_action' | /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.8.5/lib/dynflow/execution_plan/steps/abstract_flow_step.rb:7:in `execute' | /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.8.5/lib/dynflow/executors/parallel/worker.rb:15:in `block in on_message' | /opt/rh/ruby193/root/usr/share/gems/gems/algebrick-0.7.3/lib/algebrick/matchers/abstract.rb:74:in `block in assigns' | /opt/rh/ruby193/root/usr/share/gems/gems/algebrick-0.7.3/lib/algebrick/matchers/abstract.rb:73:in `tap' | /opt/rh/ruby193/root/usr/share/gems/gems/algebrick-0.7.3/lib/algebrick/matchers/abstract.rb:73:in `assigns' | /opt/rh/ruby193/root/usr/share/gems/gems/algebrick-0.7.3/lib/algebrick/matching.rb:56:in `match_value' | /opt/rh/ruby193/root/usr/share/gems/gems/algebrick-0.7.3/lib/algebrick/matching.rb:36:in `block in match?' | /opt/rh/ruby193/root/usr/share/gems/gems/algebrick-0.7.3/lib/algebrick/matching.rb:35:in `each' | /opt/rh/ruby193/root/usr/share/gems/gems/algebrick-0.7.3/lib/algebrick/matching.rb:35:in `match?' | /opt/rh/ruby193/root/usr/share/gems/gems/algebrick-0.7.3/lib/algebrick/matching.rb:23:in `match' | /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.8.5/lib/dynflow/executors/parallel/worker.rb:12:in `on_message' | /opt/rh/ruby193/root/usr/share/gems/gems/concurrent-ruby-edge-0.1.0/lib/concurrent/actor/context.rb:47:in `on_envelope' | /opt/rh/ruby193/root/usr/share/gems/gems/concurrent-ruby-edge-0.1.0/lib/concurrent/actor/behaviour/executes_context.rb:7:in `on_envelope' | /opt/rh/ruby193/root/usr/share/gems/gems/concurrent-ruby-edge-0.1.0/lib/concurrent/actor/behaviour/abstract.rb:26:in `pass' | /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.8.5/lib/dynflow/actor.rb:26:in `on_envelope' | /opt/rh/ruby193/root/usr/share/gems/gems/concurrent-ruby-edge-0.1.0/lib/concurrent/actor/behaviour/abstract.rb:26:in `pass' | /opt/rh/ruby193/root/usr/share/gems/gems/concurrent-ruby-edge-0.1.0/lib/concurrent/actor/behaviour/awaits.rb:15:in `on_envelope' | /opt/rh/ruby193/root/usr/share/gems/gems/concurrent-ruby-edge-0.1.0/lib/concurrent/actor/behaviour/abstract.rb:26:in `pass' | /opt/rh/ruby193/root/usr/share/gems/gems/concurrent-ruby-edge-0.1.0/lib/concurrent/actor/behaviour/sets_results.rb:14:in `on_envelope' | /opt/rh/ruby193/root/usr/share/gems/gems/concurrent-ruby-edge-0.1.0/lib/concurrent/actor/behaviour/abstract.rb:26:in `pass' | /opt/rh/ruby193/root/usr/share/gems/gems/concurrent-ruby-edge-0.1.0/lib/concurrent/actor/behaviour/buffer.rb:38:in `process_envelope' | /opt/rh/ruby193/root/usr/share/gems/gems/concurrent-ruby-edge-0.1.0/lib/concurrent/actor/behaviour/buffer.rb:31:in `process_envelopes?' | /opt/rh/ruby193/root/usr/share/gems/gems/concurrent-ruby-edge-0.1.0/lib/concurrent/actor/behaviour/buffer.rb:20:in `on_envelope' | /opt/rh/ruby193/root/usr/share/gems/gems/concurrent-ruby-edge-0.1.0/lib/concurrent/actor/behaviour/abstract.rb:26:in `pass' | /opt/rh/ruby193/root/usr/share/gems/gems/concurrent-ruby-edge-0.1.0/lib/concurrent/actor/behaviour/termination.rb:55:in `on_envelope' | /opt/rh/ruby193/root/usr/share/gems/gems/concurrent-ruby-edge-0.1.0/lib/concurrent/actor/behaviour/abstract.rb:26:in `pass' | /opt/rh/ruby193/root/usr/share/gems/gems/concurrent-ruby-edge-0.1.0/lib/concurrent/actor/behaviour/removes_child.rb:10:in `on_envelope' | /opt/rh/ruby193/root/usr/share/gems/gems/concurrent-ruby-edge-0.1.0/lib/concurrent/actor/behaviour/abstract.rb:26:in `pass' | /opt/rh/ruby193/root/usr/share/gems/gems/concurrent-ruby-edge-0.1.0/lib/concurrent/actor/behaviour/sets_results.rb:14:in `on_envelope' | /opt/rh/ruby193/root/usr/share/gems/gems/concurrent-ruby-edge-0.1.0/lib/concurrent/actor/core.rb:161:in `process_envelope' | /opt/rh/ruby193/root/usr/share/gems/gems/concurrent-ruby-edge-0.1.0/lib/concurrent/actor/core.rb:95:in `block in on_envelope' | /opt/rh/ruby193/root/usr/share/gems/gems/concurrent-ruby-edge-0.1.0/lib/concurrent/actor/core.rb:118:in `block (2 levels) in schedule_execution' | /opt/rh/ruby193/root/usr/share/gems/gems/concurrent-ruby-0.9.0/lib/concurrent/synchronization/monitor_object.rb:17:in `block in synchronize' | /opt/rh/ruby193/root/usr/share/ruby/monitor.rb:211:in `mon_synchronize' | /opt/rh/ruby193/root/usr/share/gems/gems/concurrent-ruby-0.9.0/lib/concurrent/synchronization/monitor_object.rb:17:in `synchronize' | /opt/rh/ruby193/root/usr/share/gems/gems/concurrent-ruby-edge-0.1.0/lib/concurrent/actor/core.rb:115:in `block in schedule_execution' | /opt/rh/ruby193/root/usr/share/gems/gems/concurrent-ruby-0.9.0/lib/concurrent/executor/serialized_execution.rb:19:in `call' | /opt/rh/ruby193/root/usr/share/gems/gems/concurrent-ruby-0.9.0/lib/concurrent/executor/serialized_execution.rb:19:in `call' | /opt/rh/ruby193/root/usr/share/gems/gems/concurrent-ruby-0.9.0/lib/concurrent/executor/serialized_execution.rb:97:in `work' | /opt/rh/ruby193/root/usr/share/gems/gems/concurrent-ruby-0.9.0/lib/concurrent/executor/serialized_execution.rb:78:in `block in call_job' | /opt/rh/ruby193/root/usr/share/gems/gems/concurrent-ruby-0.9.0/lib/concurrent/executor/ruby_thread_pool_executor.rb:332:in `call' | /opt/rh/ruby193/root/usr/share/gems/gems/concurrent-ruby-0.9.0/lib/concurrent/executor/ruby_thread_pool_executor.rb:332:in `run_task' | /opt/rh/ruby193/root/usr/share/gems/gems/concurrent-ruby-0.9.0/lib/concurrent/executor/ruby_thread_pool_executor.rb:320:in `block (3 levels) in create_worker' | /opt/rh/ruby193/root/usr/share/gems/gems/concurrent-ruby-0.9.0/lib/concurrent/executor/ruby_thread_pool_executor.rb:303:in `loop' | /opt/rh/ruby193/root/usr/share/gems/gems/concurrent-ruby-0.9.0/lib/concurrent/executor/ruby_thread_pool_executor.rb:303:in `block (2 levels) in create_worker' | /opt/rh/ruby193/root/usr/share/gems/gems/concurrent-ruby-0.9.0/lib/concurrent/executor/ruby_thread_pool_executor.rb:302:in `catch' | /opt/rh/ruby193/root/usr/share/gems/gems/concurrent-ruby-0.9.0/lib/concurrent/executor/ruby_thread_pool_executor.rb:302:in `block in create_worker' | /opt/rh/ruby193/root/usr/share/gems/gems/logging-1.8.2/lib/logging/diagnostic_context.rb:323:in `call' | /opt/rh/ruby193/root/usr/share/gems/gems/logging-1.8.2/lib/logging/diagnostic_context.rb:323:in `block in create_with_logging_context' | caused by: (RestClient::InternalServerError) Katello::Resources::Candlepin::Environment: 500 Internal Server Error {"displayMessage":"Runtime Error null at org.candlepin.model.AbstractHibernateCurator.delete:326","requestUuid":"e02be77c-5992-4b7c-8c25-6cc86e2b7017"} (DELETE /candlepin/environments/2-13/content?content=1438181785147&content=1438181717404) | /opt/rh/ruby193/root/usr/share/gems/gems/rest-client-1.6.7/lib/restclient/abstract_response.rb:48:in `return!' | /opt/rh/ruby193/root/usr/share/gems/gems/rest-client-1.6.7/lib/restclient/request.rb:230:in `process_result' | /opt/rh/ruby193/root/usr/share/gems/gems/rbovirt-0.0.35/lib/restclient_ext/request.rb:50:in `block in transmit' | /opt/rh/ruby193/root/usr/share/ruby/net/http.rb:746:in `start' | /opt/rh/ruby193/root/usr/share/gems/gems/rbovirt-0.0.35/lib/restclient_ext/request.rb:44:in `transmit' | /opt/rh/ruby193/root/usr/share/gems/gems/rest-client-1.6.7/lib/restclient/request.rb:64:in `execute' | /opt/rh/ruby193/root/usr/share/gems/gems/rest-client-1.6.7/lib/restclient/request.rb:33:in `execute' | /opt/rh/ruby193/root/usr/share/gems/gems/rest-client-1.6.7/lib/restclient/resource.rb:94:in `delete' | /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.3.0/app/lib/katello/http_resource.rb:126:in `delete' | /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.3.0/app/lib/katello/resources/candlepin.rb:508:in `delete_content' | /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.3.0/app/lib/actions/candlepin/environment/set_content.rb:41:in `run' | /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.8.5/lib/dynflow/action.rb:506:in `block (3 levels) in execute_run' | /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.8.5/lib/dynflow/middleware/stack.rb:26:in `call' | /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.8.5/lib/dynflow/middleware/stack.rb:26:in `pass' | /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.8.5/lib/dynflow/middleware.rb:16:in `pass' | /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.8.5/lib/dynflow/middleware.rb:29:in `run' | /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.8.5/lib/dynflow/middleware/stack.rb:22:in `call' | /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.8.5/lib/dynflow/middleware/stack.rb:26:in `pass' | /opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.8.5/lib/dynflow/middleware.rb:16:in `pass' | /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.3.0/app/lib/actions/middleware/propagate_candlepin_errors.rb:9:in `block in run' | ... skipped 90 lines


Related issues 1 (0 open1 closed)

Related to Katello - Bug #14465: Deleting composite view version fails with TypeError: Value (NilClass) '' is not any of: ForemanTasks::Concerns::ActionSubjectClosedBrad Buckingham04/04/2016Actions
Actions #1

Updated by Eric Helms over 8 years ago

  • translation missing: en.field_release set to 70
  • Triaged changed from No to Yes
Actions #2

Updated by Justin Sherrill over 8 years ago

  • translation missing: en.field_release changed from 70 to 86
Actions #3

Updated by Eric Helms almost 8 years ago

  • translation missing: en.field_release changed from 86 to 144
Actions #4

Updated by Justin Sherrill almost 8 years ago

  • Assignee set to Justin Sherrill
Actions #5

Updated by Justin Sherrill almost 8 years ago

Despite the different error, this was actually fixed as far as i can tell by http://projects.theforeman.org/issues/14465
https://github.com/Katello/katello/pull/5937

Moving to resolved

Actions #6

Updated by Justin Sherrill almost 8 years ago

  • Status changed from New to Resolved
Actions #7

Updated by Justin Sherrill almost 8 years ago

  • Related to Bug #14465: Deleting composite view version fails with TypeError: Value (NilClass) '' is not any of: ForemanTasks::Concerns::ActionSubject added
Actions #8

Updated by Eric Helms almost 8 years ago

  • translation missing: en.field_release changed from 144 to 86
Actions

Also available in: Atom PDF