Project

General

Profile

Bug #1171

support sha512 password hashing in RHEL6 / CentOS6

Added by Jeff Palmer almost 8 years ago. Updated over 6 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Host creation
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Currently, foreman doesn't support the "default" hashing algo used by RHEL6.

If you use the following line in your kickstart:

authconfig --useshadow --passalgo=sha512

The resulting encrypted path will not be using sha512, which means you'll get authentication errors when the host is provisioned.

My workaround right now, is to NOT let foreman encrypt the passwords.
I have foreman set the initial password to "password" (in plaintext)

rootpw password

And then on the first puppet run, I have a module that changes the password to what it should be, using SHA512.


Related issues

Is duplicate of Foreman - Feature #2127: Support newer hash schemes for root passwordsClosed2013-01-15

History

#1 Updated by Ohad Levy almost 8 years ago

  • Target version deleted (0.4)

#2 Updated by Ohad Levy over 7 years ago

I'm not sure I could reproduce this (e.g. it works with the default templates just fine), what am I missing?

#3 Updated by Benjamin Papillon over 6 years ago

This ticket will be solved when #2127 will be closed

#4 Updated by Benjamin Papillon over 6 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF