Project

General

Profile

Bug #11830

Different results when adding a parameter override from a hostgroup vs puppet class directly

Added by Michael Palmer about 5 years ago. Updated about 5 years ago.

Status:
Duplicate
Priority:
High
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

When i add an override from within a hostgroup the contents change after submitting. However, when the same change is made from within the puppet class section, the change is correct after submitting.

Here is the yaml that is being added and how it looks when submitting from the puppet class directly:

optional:
  name: RH-optional
  baseurl: http://yum-corp.example.com/rh6-x86_64/RPMS.optional/
  descr: RedHat 6 optional repo
  gpgkey: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release
base:
  name: RH-base
  baseurl: http://yum-corp.example.com/rh6-x86_64/RPMS.os/
  descr: RedHat 6 base repo
  gpgkey: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release
updates:
  name: RH-updates
  baseurl: http://yum-corp.example.com/rh6-x86_64/RPMS.updates/
  descr: RedHat 6 updates repo
  gpgkey: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release
pupdeps:
  name: RH-pupdeps
  baseurl: http://yum-corp.example.com/puppet_rh6-x86_64/RPMS.dependencies/
  descr: RedHat 6 Puppet Dependencies repo
  gpgcheck: '0'
pupproducts:
  name: RH-pupproducts
  baseurl: http://yum-corp.example.com/puppet_rh6-x86_64/RPMS.products/
  descr: RedHat 6 Puppet Products repo
  gpgcheck: '0'

Here is how it looks after submitting to the override from within the hostgroup:

--- ! "optional:\r\n  name: RH-optional\r\n  baseurl: http://yum-corp.example.com/rh6-x86_64/RPMS.optional/\r\n
  \ descr: RedHat 6 optional repo\r\n  gpgkey: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release\r\nbase:\r\n
  \ name: RH-base\r\n  baseurl: http://yum-corp.example.com/rh6-x86_64/RPMS.os/\r\n
  \ descr: RedHat 6 base repo\r\n  gpgkey: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release\r\nupdates:\r\n
  \ name: RH-updates\r\n  baseurl: http://yum-corp.example.com/rh6-x86_64/RPMS.updates/\r\n
  \ descr: RedHat 6 updates repo\r\n  gpgkey: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release\r\npupdeps:\r\n
  \ name: RH-pupdeps\r\n  baseurl: http://yum-corp.example.com/puppet_rh6-x86_64/RPMS.dependencies/\r\n
  \ descr: RedHat 6 Puppet Dependencies repo\r\n  gpgcheck: '0'\r\npupproducts:\r\n
  \ name: RH-pupproducts\r\n  baseurl: http://yum-corp.example.com/puppet_rh6-x86_64/RPMS.products/\r\n
  \ descr: RedHat 6 Puppet Products repo\r\n  gpgcheck: '0'\r\n\r\n...\r\n" 


Related issues

Is duplicate of Foreman - Bug #11375: Smart class parameters turn YAML to string when using a multi line yamlClosed2015-08-16

History

#1 Updated by Michael Palmer about 5 years ago

Katello 2.3
Foreman 1.9.1

#2 Updated by Michael Palmer about 5 years ago

This is also happening from the host level. If i select an individual host and edit the parameters on a single host, the outcome is the same as making changes from the hostgroup.

However, there is an added issue as i can't delete the override from the host level. I have to remove it from within the puppet class page.

#3 Updated by Eric Helms about 5 years ago

  • Project changed from Katello to Foreman

#4 Updated by Daniel Lobato Garcia about 5 years ago

  • Priority changed from Normal to High

#5 Updated by Dominic Cleal about 5 years ago

  • Is duplicate of Bug #11375: Smart class parameters turn YAML to string when using a multi line yaml added

#6 Updated by Dominic Cleal about 5 years ago

  • Status changed from New to Duplicate

Thanks for the report. This is unfixed but is being tracked under the ticket #11375. Regarding deleting of overrides, this should be fixed in Foreman 1.9.2 via #11807, released yesterday.

Also available in: Atom PDF