Project

General

Profile

Bug #1197

it is possible to have 2 hosts with the same name in the interface.

Added by Gustavo Soares almost 11 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Web Interface
Target version:
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

If a user saves a host specifing the fqdn (test.example.com) and then save the same host without specifing the fqdn (test) Foreman will show 2 hosts with the same name in hosts listing. Operators seems to make some confusion about that. They see the hostname registered in host's listing but don't know if they must use fqdn or not. I would be better to be explicit about that.

I don't know if this is the best approach, but here is the patch

https://github.com/gustavosoares/foreman/commit/37a2371fbb5356442769bc442a44a17b997e55ef

duplicate_hosts_example.tiff View duplicate_hosts_example.tiff 26.4 KB Gustavo Soares, 02/01/2012 01:29 PM

History

#1 Updated by Ohad Levy over 10 years ago

  • Status changed from New to Feedback

I think we already solved it with the latest view in 0.4.x

would you mind validating if this is still an issue?

thanks

#2 Updated by Gustavo Soares over 10 years ago

Yeap. This issue still affects version 0.4.

I've attached a print screen. There are two hosts registered with the short name "cittavld126". The first was created without fqdn style.. and the second with fqdn.

#3 Updated by Benjamin Papillon about 10 years ago

  • Category set to Web Interface
  • Status changed from Feedback to New

#4 Updated by Greg Sutcliffe over 9 years ago

  • Target version set to Bug scrub

#5 Updated by Greg Sutcliffe over 9 years ago

  • Status changed from New to Closed

I cannot reproduce this in 1.x develop. If you create an unmanaged host without a domain, Foreman will now append it's own domain. Thus all hosts are fully qualified, and you can't get duplicates.

Please re-open if you still hit this with the latest version.

Also available in: Atom PDF