Project

General

Profile

Bug #12020

hammer container list does not show the id

Added by Partha Aji over 7 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1230915
Description of problem:
hammer docker container list does not show the id information for the container

Version-Release number of selected component (if applicable):
S8C1

How reproducible:
Aways

Steps to Reproduce:
1. hammer container list

Actual results:
ID information is not present

Expected results:
ID information is present

Additional info:

hammer> docker container list
------------|---------------------------------------------------------------------|---------|---------|------------------------------
NAME | IMAGE REPOSITORY | TAG | COMMAND | COMPUTE RESOURCE
------------|---------------------------------------------------------------------|---------|---------|------------------------------
centos-1 | default_organization-dockerproduct-centos | 7 | top | InternalDockerComputeResource
ubuntu-1 | ubuntu | 14.04.2 | top | InternalDockerComputeResource
wordpress-1 | wordpress | 4.2 | top | InternalDockerComputeResource
test-1 | default_organization-library-dockercontentview-dockerproduct-centos | latest | top | InternalDockerComputeResource
busybox-cv | default_organization-dev-dockercontentview-dockerproduct-busybox | latest | top | InternalDockerComputeResource
------------|---------------------------------------------------------------------|---------|---------|------------------------------

Associated revisions

Revision 97fb1e82 (diff)
Added by Partha Aji over 7 years ago

Fixes #12020 - Shows container id and uuid

Many hammer cli docker container operations require UUID & Container ID.
The above code will fix that.

Revision 5e72c61e
Added by David Davis over 7 years ago

Merge pull request #17 from parthaa/uuid

Fixes #12020 - Shows container id and uuid

History

#1 Updated by Partha Aji over 7 years ago

  • Project changed from Katello to Docker

#2 Updated by Partha Aji over 7 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/hammer_cli_foreman_docker/pull/17 added
  • Pull request deleted ()

#3 Updated by Adam Ruzicka almost 7 years ago

  • Status changed from Ready For Testing to Closed

Closing since the PR was merged in October 2015 and bugzilla is closed.

Also available in: Atom PDF