Project

General

Profile

Bug #12065

Refresh host tab in job invocation detail together with overall status

Added by Ohad Levy over 7 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

when reviewing a job status, I could see multiple requests in the same second for refresh.

this is caused due to how the refresh is triggered (every time you get a response from the server, you immediately start to ask for another refresh).

IMHO this logic should be extracted from the rails response code, and managed once within the initial js that is loaded.

related, the host tab is not updated, and requires a manual update.


Related issues

Blocks Foreman Remote Execution - Feature #11865: Job invocation results host list improvementsClosed2015-09-17

Associated revisions

Revision 73236a88 (diff)
Added by Marek Hulán over 7 years ago

Fixes #12065 - refresh hosts in invocation detail

Revision eb975707
Added by Marek Hulán over 7 years ago

Merge pull request #52 from ares/fix/12065

Fixes #12065 - refresh hosts in invocation detail

Revision 5b55449e (diff)
Added by Ivan Necas over 7 years ago

Refs #12065 - fix foreman 1.9 compatibility with refresh js

Foreman 1.9 didn't include underscore.js, but we are ok with jQuery in
this case.

Revision cbaab143
Added by Ivan Necas over 7 years ago

Merge pull request #54 from iNecas/hosts-refresh-19

Refs #12065 - fix foreman 1.9 compatibility with refresh js

History

#1 Updated by Marek Hulán over 7 years ago

I don't follow, with every response there's 1 second timeout so next refresh is in interval = (response time + 1 second). If the refresh is triggered more frequently, it might be bug in JS but not caused by the fact that JS is sent in response?

#2 Updated by Ohad Levy over 7 years ago

Yes you are right, was reading it wrong.

then in this case, we can convert this issue to the host tab not updating? (maybe we can update it on click vs in the background)? and refresh it if its active?

#3 Updated by Marek Hulán over 7 years ago

  • Subject changed from job review refresh interval is too high to Refresh host tab in job invocation detail together with overall status
  • Status changed from New to Assigned
  • Assignee set to Marek Hulán
  • Target version set to 87

I think it will be more efficient to do the update together in same request for which we do the chart update. We won't refresh the whole table, just hosts that hasn't finish the run yet. Otherwise we'd have to deal with pagination, also is user would select some text it would remove the selection etc...

#4 Updated by The Foreman Bot over 7 years ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/foreman_remote_execution/pull/52 added
  • Pull request deleted ()

#5 Updated by Marek Hulán over 7 years ago

  • Blocks Feature #11865: Job invocation results host list improvements added

#6 Updated by Marek Hulán over 7 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100
  • Legacy Backlogs Release (now unused) set to 99

#7 Updated by Ivan Necas over 7 years ago

  • Legacy Backlogs Release (now unused) changed from 99 to 101

Also available in: Atom PDF