Project

General

Profile

Bug #12112

The hammer does not prompt for username and password when wrong credentials are provided

Added by Bryan Kearney over 4 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
Foreman commands (obsolete)
Target version:
Difficulty:
Triaged:
No
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:
In Kanboard:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1214555
Description of problem:

When executing a commands in hammer shell it prompts for username and password, if we provide wrong username or password then for any commands after that it only shows message "Invalid username or password",

[Foreman] Username: admin
[Foreman] Password for admin:
Invalid username or password
hammer> capsule list
Invalid username or password
hammer> subnet list
Invalid username or password

Version-Release number of selected component (if applicable):

6.1

How reproducible:

Everytime

Steps to Reproduce:
1. Login to hammer shell using "hammer shell".
2. Try to run any command like, when it would ask for username and password provide wrong credentials.
3. Try to execute any commands after this, it would not prompt for username and password again, instead will show message "Invalid username or password"

Actual results:

Does not ask credential if credentials provided first time are wrong.

Expected results:

Should ask for new credentials if first time provide credentials are wrong.

Additional info:

History

#1 Updated by Alon Goldboim over 4 years ago

  • Category set to Foreman commands (obsolete)
  • Assignee changed from Martin Bacovsky to Alon Goldboim

#2 Updated by The Foreman Bot over 4 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/hammer-cli-foreman/pull/199 added
  • Pull request deleted ()

#3 Updated by Alon Goldboim over 4 years ago

  • Pull request https://github.com/Apipie/apipie-bindings/pull/32 added
  • Pull request deleted (https://github.com/theforeman/hammer-cli-foreman/pull/199)

#4 Updated by Tomáš Strachota over 4 years ago

  • Target version set to hammer-cli 0.5.0

#5 Updated by Tomáš Strachota over 4 years ago

  • Status changed from Ready For Testing to Closed

Closing since the PR has been merged into apipie-bindings.

Also available in: Atom PDF