Project

General

Profile

Feature #12119

Partition table has limit 4096

Added by Lukas Zapletal almost 5 years ago. Updated almost 5 years ago.

Status:
Duplicate
Priority:
Normal
Category:
Database
Target version:
-
Difficulty:
trivial
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

There is a request coming from Satellite 6 customer to increase the limit. Since this is a text field, it should be possible to unlimit this, so only SQL platform limits that (e.g. SQLite 100000 chars by default, PostgreSQL no limit).

Creating a patch with 20,000 as a default, let's discuss this.


Related issues

Is duplicate of Foreman - Bug #3008: Partition table is truncatedClosed2013-09-02

History

#1 Updated by Dominic Cleal almost 5 years ago

  • Is duplicate of Bug #3008: Partition table is truncated added

#2 Updated by Dominic Cleal almost 5 years ago

  • Status changed from New to Duplicate

#3008 fixed this in 1.8, and since 1.9 partition tables are templates with the same limits.

#3 Updated by Lukas Zapletal almost 5 years ago

Sorry what? I can see the limit right there, in develop branch.

#4 Updated by Lukas Zapletal almost 5 years ago

Hmm I still see it in schema.rb... That confused me. Okay.

#5 Updated by Dominic Cleal almost 5 years ago

#3008 should have changed the limit in 1.8, perhaps it's buggy. However #7096 changed partition tables to be Template subclasses, so they're no longer stored in the ptables table anyway.

(I filed #12120 to drop the unused table.)

Also available in: Atom PDF