Project

General

Profile

Bug #12393

Overriding the parameter default value doent adds 1 to the 'Number of Values' count.

Added by Jitendra Yejare almost 4 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Low
Assignee:
Category:
Web Interface
Target version:
Difficulty:
Triaged:
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Description of problem:
Overriding the parameter default value doent adds 1 to the 'Number of Values' count in parameters table in Config -> Smart Class Parameter page.

Version-Release number of selected component (if applicable):

How reproducible:
Always

Steps to Reproduce:
1. Override smart class parameter, set the default value.
2. Don't check 'puppet default value' checkbox.
3. See the 'Number Of Values' column for that parameter in Config -> Smart Class Parameters.

Actual results:
The count doesn't adds 1 to the 'Number of Values' for that parameter.

Expected results:
The count for 'Number of Values' should be increased by 1.

Associated revisions

Revision c49222be (diff)
Added by Tomer Brisker over 3 years ago

Fixes #12393 - Clarify parameter override count column header

History

#1 Updated by Dominic Cleal almost 4 years ago

  • Status changed from New to Feedback
  • Legacy Backlogs Release (now unused) deleted (71)

Please don't set the release field.

Setting the default value is not creating an override, that's the section at the bottom of the form with specific matchers. This appears to be correct behaviour to me.

#2 Updated by Jitendra Yejare over 3 years ago

Dominic Cleal wrote:

Please don't set the release field.

Setting the default value is not creating an override, that's the section at the bottom of the form with specific matchers. This appears to be correct behaviour to me.

But the column says the 'number of values' the parameter has and by giving default value which is atleast one value. And so I believe this needs to be fixed.
It will also help to identify that What are the parameters whose only default value has been overrided from table itself.

#3 Updated by Dominic Cleal over 3 years ago

  • Status changed from Feedback to New
  • Assignee deleted (Tomer Brisker)
  • Priority changed from Normal to Low

It'd be better to call it the number of overrides since it's a counter, and if you need some way to indicate the presence of a default value, to indicate it another way.

#4 Updated by The Foreman Bot over 3 years ago

  • Status changed from New to Ready For Testing
  • Assignee set to Tomer Brisker
  • Pull request https://github.com/theforeman/foreman/pull/3179 added

#5 Updated by Anonymous over 3 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#6 Updated by Dominic Cleal over 3 years ago

  • Legacy Backlogs Release (now unused) set to 71

Also available in: Atom PDF