Project

General

Profile

Bug #12954

Foreman puppet report status does not work without a puppet proxy

Added by Chuck Schweizer over 3 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Reporting
Target version:
Difficulty:
trivial
Triaged:
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

As of foreman 1.10.0 the host_status table is not updated with puppet report status if your puppet masters are not official puppet proxy servers.

https://github.com/theforeman/foreman/blob/1.10-stable/app/models/host_status/configuration_status.rb#L81

This breaks configurations that use foreman as a report backend but do not make use of the foreman proxy code.


Related issues

Related to Foreman - Bug #11771: Saving host without particular status failsClosed2015-09-10
Related to Foreman - Bug #13112: N+1 query on hosts#index from last report objectClosed2016-01-11

Associated revisions

Revision 8660f934 (diff)
Added by Dominic Cleal over 3 years ago

fixes #12954 - config status is relevant if reports exist or via setting

For a host that has config management reports, but no Puppet proxy set,
consider the config status relevant. This helps in an environment with
reports but no proxy, but has the side effect of considering the status
still relevant even if a host has a proxy unset and old reports.

Also add a setting to restore 1.9 behaviour of always showing config
status, so users with no smart proxies will see the "No reports" status
for those hosts without reports. All hosts without reports will show a
warning state when the setting is enabled.

Test changes prevent setting changes leaking out of unit tests.

Revision dd561749 (diff)
Added by Dominic Cleal over 3 years ago

fixes #12954 - config status is relevant if reports exist or via setting

For a host that has config management reports, but no Puppet proxy set,
consider the config status relevant. This helps in an environment with
reports but no proxy, but has the side effect of considering the status
still relevant even if a host has a proxy unset and old reports.

Also add a setting to restore 1.9 behaviour of always showing config
status, so users with no smart proxies will see the "No reports" status
for those hosts without reports. All hosts without reports will show a
warning state when the setting is enabled.

Test changes prevent setting changes leaking out of unit tests.

(cherry picked from commit 8660f934e6e75c2acaeeacd5d009dabcbd41a326)

History

#1 Updated by Ohad Levy over 3 years ago

#2 Updated by Dominic Cleal over 3 years ago

  • Related to Bug #11771: Saving host without particular status fails added

#3 Updated by Dominic Cleal over 3 years ago

  • Legacy Backlogs Release (now unused) set to 104

#4 Updated by Dominic Cleal over 3 years ago

  • Status changed from New to Assigned
  • Assignee set to Dominic Cleal

#5 Updated by The Foreman Bot over 3 years ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/3028 added

#6 Updated by Dominic Cleal over 3 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#7 Updated by Dominic Cleal over 3 years ago

  • Legacy Backlogs Release (now unused) changed from 104 to 71

#13112 is a regression, moving to 1.11 until resolved - and it may require an internal API change to fix. Will move it back if it turns out not to.

#8 Updated by Dominic Cleal over 3 years ago

  • Related to Bug #13112: N+1 query on hosts#index from last report object added

#9 Updated by Dominic Cleal over 3 years ago

  • Legacy Backlogs Release (now unused) changed from 71 to 104

#10 Updated by rajeev jaggavarapu about 3 years ago

  • Copied to Support #15571: "Invalid keyfile or passphrase" when saving GCE compute resource added

#11 Updated by Dominic Cleal about 3 years ago

  • Copied to deleted (Support #15571: "Invalid keyfile or passphrase" when saving GCE compute resource)

Also available in: Atom PDF