Project

General

Profile

Bug #1310

Inconsistent Host rendering

Added by Greg Sutcliffe almost 8 years ago. Updated almost 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Web Interface
Target version:
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Looks like the JS is failing to parse the incoming JSON for the graphs - not too bad by itself, but it breaks the rendering of the Edit/Build/Etc buttons too.

Attached are the HTML, JS log, and screenshot.

js.png View js.png 123 KB The Javascript error console Greg Sutcliffe, 11/10/2011 09:00 AM
web.png View web.png 94.9 KB The displayed result Greg Sutcliffe, 11/10/2011 09:00 AM
html.txt html.txt 48.7 KB Page source Greg Sutcliffe, 11/10/2011 09:00 AM
0001-Changed-reported_at-to-created_at-to-solve-a-bug-cau.patch 0001-Changed-reported_at-to-created_at-to-solve-a-bug-cau.patch 949 Bytes Amos Benari, 11/13/2011 03:54 AM
Js Web

History

#1 Updated by Ohad Levy almost 8 years ago

  • Category set to Web Interface
  • Target version set to 1.0

#2 Updated by Amos Benari almost 8 years ago

My guess is that the problem is caused because some of the report 'reported_at' field contains a wrong data.
In the attached patch I have changed the reported_at to created_at as the time of the report, this is less accurate but much safer time stamp.

#3 Updated by Ohad Levy almost 8 years ago

  • Target version changed from 1.0 to 0.4.1

#4 Updated by Greg Sutcliffe almost 8 years ago

Seems to be a bug in the JSON gem (v 1.5.2). Upgrading JSON to 1.6.1 and retstarting the passenger instance seems to have fixed it. Thanks :)

#5 Updated by Ohad Levy almost 8 years ago

  • Status changed from Ready For Testing to Resolved

Also available in: Atom PDF