Project

General

Profile

Bug #13332

ContentViews: Excluded packages apply to all repositories instead of only the affected ones.

Added by Sebastian @ over 3 years ago. Updated 11 months ago.

Status:
Rejected
Priority:
High
Category:
-
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

When exclude a rpm in the filter of a content view and set affected repositories only to a single repo it gets disabled for all repos instead.
Example:
We mirrored centos7 and remi into different products.
Disabled php on the remi repo via filter.

Expectation:
Package php is still available from the centos7-os repo

Reality:
Package php is no longer available at all.

History

#1 Updated by Sebastian @ over 3 years ago

Version 2.4 sorry forgot that

#2 Updated by Eric Helms over 3 years ago

  • Legacy Backlogs Release (now unused) set to 113

#3 Updated by Eric Helms over 3 years ago

  • Assignee set to Partha Aji

#4 Updated by Justin Sherrill over 3 years ago

  • Assignee changed from Partha Aji to Justin Sherrill

For the life of me I can't reproduce this.

What does your filter look like? just 'php'?
Are you sure you're hitting 'update repositories' on the affected repositories tab of the filter?

#5 Updated by Justin Sherrill over 3 years ago

  • Legacy Backlogs Release (now unused) changed from 113 to 86

#6 Updated by Eric Helms about 3 years ago

  • Status changed from New to Rejected
  • Legacy Backlogs Release (now unused) changed from 86 to 114

I tested this with 3.0 and everything worked as expected for me as well, moving to rejected. If you are still seeing this after ensuring that you hit update repositories please re-open.

Also available in: Atom PDF