Project

General

Profile

Feature #13340

Seed Fedora Atomic installation media

Added by Daniel Lobato Garcia almost 4 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Category:
Unattended installations
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Fedora atomic now has a repository where you can get the isolinux stuff from - https://dl.fedoraproject.org/pub/alt/atomic/stable/Cloud_Atomic/x86_64/os/ . This allows us to perform fully unattended installations through foreman. Before, you would have to download the image and prepare your own local installation media to PXE boot it (http://blog.daniellobato.me/unattended-deployments-of-fedora-and-rhel-atomic-with-foreman/).

We still have a problem. The URL used for isolinux is completely different from the URL `ostreesetup` in the Kickstart needs to pull the ostree. That URL looks like this: https://dl.fedoraproject.org/pub/fedora/linux/atomic/22/

The problem is circumvented on the Kickstart [1] the best way I could given the prior circumstances, we pass a parameter 'atomic-upstream' to any hosts that you want to provision with upstream Atomic, but the isolinux stuff had to be downloaded from the local installation media. Should I change the kickstart to disregard that parameter and always use the upstream URL now that we can? It'd mean people who want a local installation media would have to change the Kickstart to take that into account.

[1] - https://github.com/theforeman/community-templates/blob/develop/kickstart/provision_atomic.erb#L21

Associated revisions

Revision 45ed087a (diff)
Added by Daniel Lobato Garcia almost 4 years ago

Fixes #13340 - Seed Fedora Atomic installation media

Fedora Atomic now has a repository where you can get the isolinux stuff
from -https://dl.fedoraproject.org/pub/alt/atomic/stable/Cloud_Atomic/x86_64/os/

This allows us to perform fully unattended installations through
foreman. Before, you would have to download the image and prepare your
own local installation media to PXE boot it
(http://blog.daniellobato.me/unattended-deployments-of-fedora-and-rhel-atomic-with-foreman/).

History

#1 Updated by The Foreman Bot almost 4 years ago

  • Status changed from New to Ready For Testing
  • Assignee set to Daniel Lobato Garcia
  • Pull request https://github.com/theforeman/foreman/pull/3111 added

#2 Updated by Daniel Lobato Garcia almost 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#3 Updated by Dominic Cleal almost 4 years ago

  • Legacy Backlogs Release (now unused) set to 71

Also available in: Atom PDF