Project

General

Profile

Bug #13502

Build failure on RHEL 7.2 - docker moved to separate package

Added by Lukas Zapletal about 4 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Category:
Packaging
Target version:
Difficulty:
Triaged:
Bugzilla link:

Description

I need reverse order of optional_policy/ifndef introduced in #11934 because it fails to build:

Compiling targeted foreman module
foreman.te:413: Warning: miscfiles_read_certs() has been deprecated, please use miscfiles_read_generic_certs() instead.
foreman.te":377:ERROR 'syntax error' at token 'docker_stream_connect' on line 7954:
            docker_stream_connect(passenger_t)
#line 377
/usr/bin/checkmodule:  error(s) encountered while parsing configuration
/usr/bin/checkmodule:  loading policy configuration from tmp/foreman.tmp
make[1]: Leaving directory `/builddir/build/BUILD/foreman-selinux-1.11.0/local-tmp-foreman'
make[1]: *** [tmp/foreman.mod] Error 1
make: *** [foreman.pp] Error 2

Associated revisions

Revision eb34a92f (diff)
Added by Lukas Zapletal almost 4 years ago

fixes #13502 - introduced has_docker definition

We fail hard when docker is not present because it was part of core policy
and was moved to separate package in RHEL 7.2. We might change this to a
warning in future major release of RHEL.

History

#1 Updated by Lukas Zapletal about 4 years ago

After taking second look, it might not be caused by the optional block, investigating. I guess SELinux broke the API again.

#2 Updated by Lukas Zapletal about 4 years ago

  • Subject changed from Build failure on RHEL 7.2 due to optional policy block: to Build failure on RHEL 7.2 - docker moved to separate package

Docker policy was removed from RHEL 7.2 base policy and moved to docker-selinux subpackage:

https://github.com/lzap/centos-selinux-interface/blob/master/centos-7.1-vs-7.2.diff
http://mirror.centos.org/centos/7.2.1511/extras/x86_64/Packages/

The package is is extras which is enabled by default in CentOS 7.

Therefore we only need to add a build RPM dependency. For runtime this is not required as this is in optional block, therefore this will only be loaded when docker is present I believe. If this is not true, then we need to add "rhel-7-server-extras-rpms" to our installation instructions on RHEL 7.

#3 Updated by The Foreman Bot about 4 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman-selinux/pull/56 added

#4 Updated by The Foreman Bot about 4 years ago

  • Pull request https://github.com/theforeman/foreman-packaging/pull/1006 added

#6 Updated by Dominic Cleal almost 4 years ago

  • Category set to Packaging

#7 Updated by Anonymous almost 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#8 Updated by Dominic Cleal almost 4 years ago

  • Legacy Backlogs Release (now unused) set to 141

Also available in: Atom PDF