Project

General

Profile

Bug #13560

Remote execution smart-proxy fails on debian because of lacking dynflow sqlite directory

Added by Rolf Larsen almost 4 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Debian Jessie
Foreman 1.10.1
ii ruby-foreman-remote-execution 0.2.2-1 all Foreman Remote Execution Plugin
ii ruby-smart-proxy-remote-execution-ssh 0.0.12-1 all SSH remote execution provider for Foreman smart proxy

proxy.log:

E, [2016-02-04T12:01:03.070070 #21126] ERROR -- : SQLite3::CantOpenException: unable to open database file (Sequel::DatabaseConnectionError)
/usr/lib/ruby/vendor_ruby/sequel/adapters/sqlite.rb:107:in `initialize'
/usr/lib/ruby/vendor_ruby/sequel/adapters/sqlite.rb:107:in `new'
/usr/lib/ruby/vendor_ruby/sequel/adapters/sqlite.rb:107:in `connect'
/usr/lib/ruby/vendor_ruby/sequel/connection_pool.rb:96:in `make_new'
/usr/lib/ruby/vendor_ruby/sequel/connection_pool/threaded.rb:158:in `make_new'
/usr/lib/ruby/vendor_ruby/sequel/connection_pool/threaded.rb:137:in `available'
/usr/lib/ruby/vendor_ruby/sequel/connection_pool/threaded.rb:127:in `block in acquire'
/usr/lib/ruby/vendor_ruby/sequel/connection_pool/threaded.rb:194:in `block in sync'
/usr/lib/ruby/vendor_ruby/sequel/connection_pool/threaded.rb:194:in `synchronize'
/usr/lib/ruby/vendor_ruby/sequel/connection_pool/threaded.rb:194:in `sync'
/usr/lib/ruby/vendor_ruby/sequel/connection_pool/threaded.rb:126:in `acquire'
/usr/lib/ruby/vendor_ruby/sequel/connection_pool/threaded.rb:94:in `hold'
/usr/lib/ruby/vendor_ruby/sequel/database/connecting.rb:250:in `synchronize'
/usr/lib/ruby/vendor_ruby/sequel/adapters/sqlite.rb:140:in `execute_ddl'
/usr/lib/ruby/vendor_ruby/sequel/database/schema_methods.rb:639:in `create_table_from_generator'
/usr/lib/ruby/vendor_ruby/sequel/database/schema_methods.rb:195:in `create_table'
/usr/lib/ruby/vendor_ruby/sequel/database/schema_methods.rb:221:in `create_table?'
/usr/lib/ruby/vendor_ruby/sequel/extensions/migration.rb:586:in `schema_dataset'
/usr/lib/ruby/vendor_ruby/sequel/extensions/migration.rb:444:in `initialize'
/usr/lib/ruby/vendor_ruby/sequel/extensions/migration.rb:506:in `initialize'
/usr/lib/ruby/vendor_ruby/sequel/extensions/migration.rb:391:in `new'
/usr/lib/ruby/vendor_ruby/sequel/extensions/migration.rb:391:in `run'
/usr/lib/ruby/vendor_ruby/dynflow/persistence_adapters/sequel.rb:218:in `migrate_db'
/usr/lib/ruby/vendor_ruby/dynflow/persistence_adapters/sequel.rb:44:in `initialize'
/usr/lib/ruby/vendor_ruby/smart_proxy_dynflow.rb:34:in `new'
/usr/lib/ruby/vendor_ruby/smart_proxy_dynflow.rb:34:in `persistence_adapter'
/usr/lib/ruby/vendor_ruby/smart_proxy_dynflow.rb:41:in `block in default_world_config'
/usr/lib/ruby/vendor_ruby/smart_proxy_dynflow.rb:38:in `tap'
/usr/lib/ruby/vendor_ruby/smart_proxy_dynflow.rb:38:in `default_world_config'
/usr/lib/ruby/vendor_ruby/smart_proxy_dynflow.rb:16:in `create_world'
/usr/lib/ruby/vendor_ruby/smart_proxy_dynflow.rb:12:in `initialize'
/usr/lib/ruby/vendor_ruby/smart_proxy_dynflow.rb:55:in `new'
/usr/lib/ruby/vendor_ruby/smart_proxy_dynflow.rb:55:in `ensure_initialized'
/usr/lib/ruby/vendor_ruby/smart_proxy_dynflow.rb:68:in `block in web_console'
/usr/lib/ruby/vendor_ruby/dynflow/web.rb:10:in `instance_exec'
/usr/lib/ruby/vendor_ruby/dynflow/web.rb:10:in `block in setup'
/usr/lib/ruby/vendor_ruby/sinatra/base.rb:2026:in `class_eval'
/usr/lib/ruby/vendor_ruby/sinatra/base.rb:2026:in `new'
/usr/lib/ruby/vendor_ruby/dynflow/web.rb:10:in `setup'
/usr/lib/ruby/vendor_ruby/smart_proxy_dynflow.rb:62:in `web_console'
(eval):5:in `block (4 levels) in https_app'
/usr/lib/ruby/vendor_ruby/rack/builder.rb:55:in `instance_eval'
/usr/lib/ruby/vendor_ruby/rack/builder.rb:55:in `initialize'
/usr/lib/ruby/vendor_ruby/rack/builder.rb:145:in `new'
/usr/lib/ruby/vendor_ruby/rack/builder.rb:145:in `block in generate_map'
/usr/lib/ruby/vendor_ruby/rack/builder.rb:145:in `each'
/usr/lib/ruby/vendor_ruby/rack/builder.rb:145:in `generate_map'
/usr/lib/ruby/vendor_ruby/rack/builder.rb:132:in `to_app'
/usr/lib/ruby/vendor_ruby/rack/builder.rb:138:in `call'
/usr/lib/ruby/vendor_ruby/rack/urlmap.rb:65:in `block in call'
/usr/lib/ruby/vendor_ruby/rack/urlmap.rb:50:in `each'
/usr/lib/ruby/vendor_ruby/rack/urlmap.rb:50:in `call'
/usr/lib/ruby/vendor_ruby/rack/builder.rb:138:in `call'
/usr/lib/ruby/vendor_ruby/rack/handler/webrick.rb:60:in `service'
/usr/lib/ruby/2.1.0/webrick/httpserver.rb:138:in `service'
/usr/lib/ruby/2.1.0/webrick/httpserver.rb:94:in `run'
/usr/lib/ruby/2.1.0/webrick/server.rb:295:in `block in start_thread'

# cat /etc/foreman-proxy/settings.d/dynflow.yml
---
:enabled: true
:database: /var/spool/foreman-proxy/dynflow/dynflow.sqlite

And /var/spool/foreman-proxy is not created by the package.

Solution:

mkdir -p /var/spool/foreman-proxy/dynflow
chown -R foreman-proxy.foreman-proxy /var/spool/foreman-proxy


Related issues

Is duplicate of Foreman Remote Execution - Bug #13415: Remote execution smart-proxy fails because of lacking dynflow sqlite directoryResolved2016-01-27

History

#1 Updated by Stephen Benjamin almost 4 years ago

  • Is duplicate of Bug #13415: Remote execution smart-proxy fails because of lacking dynflow sqlite directory added

#2 Updated by Marek Hulán almost 4 years ago

  • Related to Bug #13415: Remote execution smart-proxy fails because of lacking dynflow sqlite directory added

#3 Updated by Stephen Benjamin almost 4 years ago

  • Status changed from New to Duplicate

Looks like we knew about it, it just didn't have a good title

Thanks!

#4 Updated by Stephen Benjamin almost 4 years ago

  • Related to deleted (Bug #13415: Remote execution smart-proxy fails because of lacking dynflow sqlite directory)

Also available in: Atom PDF