Project

General

Profile

Bug #13694

compute resource provider from plugin missing sometimes

Added by Thomas McKay over 6 years ago. Updated over 6 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Compute resources
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

I have not consistently reproduced this but there seems to be a situation where the compute resource model is loaded after a plugin (docker) has registered itself as a provider. This results in it being missing from the list of supported_providers.

https://github.com/theforeman/foreman/blob/develop/app/models/compute_resource.rb#L13


  class_attribute :supported_providers
  self.supported_providers = {
    'Libvirt'   => 'Foreman::Model::Libvirt',
    'Ovirt'     => 'Foreman::Model::Ovirt',
    'EC2'       => 'Foreman::Model::EC2',
    'Vmware'    => 'Foreman::Model::Vmware',
    'Openstack' => 'Foreman::Model::Openstack',
    'Rackspace' => 'Foreman::Model::Rackspace',
    'GCE'       => 'Foreman::Model::GCE',
  }


Related issues

Is duplicate of Foreman - Bug #12746: Compute resources can disappear in a development instanceClosed2015-12-08

History

#1 Updated by Dominic Cleal over 6 years ago

  • Is duplicate of Bug #12746: Compute resources can disappear in a development instance added

#2 Updated by Dominic Cleal over 6 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF