Project

General

Profile

Bug #13750

'hidden value' flag is not listed in hammer parameter info output

Added by Jitendra Yejare over 4 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Foreman commands (obsolete)
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:
In Kanboard:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1309226
Description of problem:
hidden value flag is not displayed in the output of hammer sc-param info --id <id>.

Version-Release number of selected component (if applicable):
foreman-1.11.0-0.develop.201601251557git59dc77b.el6.noarch

How reproducible:
Always

Steps to Reproduce:
1. From hammer CLI, info some parameter
  1. hammer sc-param info --id <id>

Actual results:
The 'hidden value' flag for that parameter is not displayed/listed in output.
Output:
#hammer sc-param info --id 319
Ignoring ruby-libvirt-0.5.2 because its extensions are not built. Try: gem pristine ruby-libvirt --version 0.5.2
Id: 319
Parameter: admin_password
Default Value: [123]
Override: true
Puppet class: nova::api
Description: sadsa dsadwq 3r q3rq f fdfs dfdsf dsd 23e 3rrdsf dsdsfdfdf 323e3 ewewe#####!*()*&(&&$%%#$#
Type: array
Required: false
Validator:
Type:
Rule: kit,sit
Override values:
Merge overrides: no
Merge default value: no
Avoid duplicates: no
Order: hostgroup, organization, fqdn, domain, os
Values:
1) Id: 26
Match: os=rhel76
Value: ["sit"]
Environments:
KT_Default_Organization_Library_cv_puppet_2
Created at: 2016/01/27 10:18:52
Updated at: 2016/02/17 09:23:59

Expected results:
'hidden value' flag should be added/displayed in info output of sc-param.

Additional info:

Associated revisions

Revision b4168656 (diff)
Added by Ori Rabin over 4 years ago

Fixes #13750 - Showing hidden_value? for smart variables and class parameters

Revision 7ba1ca11
Added by Tomas Strachota over 4 years ago

Merge pull request #214 from orrabin/13750

Fixes #13750 - Showing hidden_value? for smart variables and class parameters

History

#1 Updated by Dominic Cleal over 4 years ago

  • Project changed from Foreman to Hammer CLI
  • Category set to Foreman commands (obsolete)

#2 Updated by The Foreman Bot over 4 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/hammer-cli-foreman/pull/214 added

#3 Updated by Ori Rabin over 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF