Project

General

Profile

Bug #1379

SUSE OS defined more generically if lsb is installed

Added by Jacob McCann about 11 years ago. Updated about 11 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

I have 2 SUSE systems (well more, but 2 for this example).

One with LSB installed shows up in foreman as "SLES 10". The other without LSB installed shows up as "SLES 10.4". Both are SLES 10.4

I'm guessing that with lsb installed the OS information provided by lsb facts override whatever other process is used to figure out the OS on SLES systems. However, LSB does not give a minor so in foreman the system is more generically defined.

System that shows up as "SLES 10":

hostnameA:~ # rpm -qa | grep lsb
lsb-3.1-1.7
hostnameA:~ # facter -p | grep lsb
lsbdistcodename => n/a
lsbdistdescription => SUSE Linux Enterprise Server 10 (x86_64)
lsbdistid => SUSE LINUX
lsbdistrelease => 10
lsbmajdistrelease => 10
lsbrelease => core-2.0-noarch:core-3.0-noarch:core-2.0-x86_64:core-3.0-x86_64:desktop-3.1-amd64:desktop-3.1-noarch:graphics-2.0-amd64:graphics-2.0-noarch:graphics-3.1-amd64:graphics-3.1-noarch
hostnameA:~ # facter -p | grep 10
lsbdistdescription => SUSE Linux Enterprise Server 10 (x86_64)
lsbdistrelease => 10
lsbmajdistrelease => 10
operatingsystemrelease => 10.4
usps_oracle_hp_hugepages => 1024
usps_os_dist => sles10
usps_os_version => 10
usps_patch_date => 20110826
hostnameA:~ # cat /etc/SuSE-release 
SUSE Linux Enterprise Server 10 (x86_64)
VERSION = 10
PATCHLEVEL = 4

System that shows up as "SLES 10.4":

hostnameB:~ # rpm -q lsb
package lsb is not installed
hostnameB:~ # facter -p | grep lsb
hostnameB:~ # facter -p | grep 10
operatingsystemrelease => 10.4
usps_os_dist => sles10
usps_os_version => 10
hostnameB:~ # cat /etc/SuSE-release
SUSE Linux Enterprise Server 10 (x86_64)
VERSION = 10
PATCHLEVEL = 4

I've also removed the lsb package on hostnameA and ran puppet again, and then "SLES 10.4" shows up as expected.


Related issues

Is duplicate of Foreman - Bug #1176: SLES (SUSE) operatingsystem not displaying minor version?Closed2011-09-20

History

#1 Updated by Oliver Weinmann about 11 years ago

Hi,

I have raised a similar Ticket 3 months ago:

http://theforeman.org/issues/1176

Maybe these two tickets can be merged to speedup the process.

Regards,
Oliver

#2 Updated by Ohad Levy about 11 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF