Project

General

Profile

Bug #1380

/has_many_polymorphs.git (at master) is not checked out. Please run `bundle install` (Bundler::GitError)

Added by Florian Koch over 7 years ago. Updated about 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Packaging
Target version:
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Hi,

fresh installation of develop branch. using sl6.1 and passenger
bundle install says

Your bundle is complete! Use `bundle show [gemname]` to see where a bundled gem is installed.

If i try to access foreman, i got an error

see attached screenshot

foreman-bundle-bug.png View foreman-bundle-bug.png 53.5 KB Florian Koch, 12/07/2011 03:12 PM
Foreman bundle bug

Related issues

Related to Foreman - Bug #1367: Ensure all gems are defined in Bundler GemfileClosed2011-12-04

History

#1 Updated by Florian Koch over 7 years ago

The solution is to run bundle install with --development (this is installation system wide / in verndor/rails)

Look here
http://www.ruby-forum.com/topic/213962#947322

mayee the problem is that i run foreman under root and not foreman

#2 Updated by Greg Sutcliffe over 7 years ago

I solved this by running "bundle install --path vendor/" in /usr/share/foreman (Debian Squeeze). I need to check if that's a valid method from a clean Debian install though...

#3 Updated by Oliver Weinmann over 7 years ago

Hi,

I'm running Ubuntu 10.04. The fix doesn't work for me. :(

Restarting Apache after:

bundle install --path vendor/

gives me a new error:

Puppet is not missing constant Resource!

#4 Updated by Oliver Weinmann over 7 years ago

Thanks to Ohad:

echo "gem 'puppet'" >> Gemfile
bundle install --path vendor

fixed it.

#5 Updated by Ohad Levy over 7 years ago

  • Category changed from Power management to Packaging

#6 Updated by Ohad Levy about 7 years ago

  • Status changed from New to Closed

I'm closing this one, as it seems like it does work for the current compute.

once released, we'll support official packages (somehow) :)

Also available in: Atom PDF