Project

General

Profile

Actions

Bug #14132

closed

Cannot provision GCE instance with external IP flag

Added by El Joppa over 8 years ago. Updated over 5 years ago.

Status:
Duplicate
Priority:
High
Assignee:
-
Category:
Compute resources - GCE
Target version:
-
Difficulty:
Triaged:
No
Fixed in Releases:
Found in Releases:

Description

Hitting the flag "External IP" in Virtual Machine tab gives me the following message:

Unable to save
Failed to create a compute Google_Operations (europe-west1-b-Google) instance test-gce2.X.no: Invalid value for field 'resource.networkInterfaces[0].accessConfigs[0].natIP': 'true'. Must be an IP address 

Without this flag i get a private address for the VM with ip 10.240.x.x

Any quickfix to make this work?


Related issues 2 (1 open1 closed)

Related to Foreman - Bug #14282: Foreman GCE can't create new host on custom sub networkNewActions
Is duplicate of Foreman - Bug #4179: Invalid value for field 'resource.networkInterfaces[0].accessConfigs[0].natIP': 'false'. Must be an IP addressClosedKavita GaikwadActions
Actions #1

Updated by El Joppa over 8 years ago

From /usr/share/foreman/vendor/ruby/2.1.0/gems/fog-google-0.1.0/lib/fog/google/requests/compute/insert_server.rb:

          # ExternalIP is default value for server creation
          access_config = {'type' => 'ONE_TO_ONE_NAT', 'name' => 'External NAT'}
          # leave natIP undefined to use an IP from a shared ephemeral IP address pool
          if options.key? 'externalIp'
            access_config['natIP'] = options.delete 'externalIp'
            # If set to 'false', that would mean user does no want to allocate an external IP
            access_config = nil if access_config['natIP'] == false
          end

So resource.networkInterfaces0.accessConfigs0.nat should be undefined if one wants a ephemeral IP assigned?

Actions #2

Updated by Dominic Cleal over 8 years ago

  • Category set to Compute resources - GCE
Actions #3

Updated by Aanjaneya Mishra over 8 years ago

'resource.networkInterfaces[0].accessConfigs[0].natIP': 'true'. Must be an IP address

also if I fiddle with subnets and interface names or provide internal IP then it gives someting like no subnetwork defined for custom network.

I have spent two days on it. This problem just doesn't let me go forward. Possibly I shoud try to create a new gce instance using gcloud or web console: manually install puppet agent/salt-minion on it and then add it to foreman.

Do not have a clue as I just discovered foreman a few days ago.

A few hints about workaroud might be helpful.

Actions #4

Updated by Dominic Cleal over 8 years ago

  • Related to Bug #14282: Foreman GCE can't create new host on custom sub network added
Actions #5

Updated by Kavita Gaikwad over 5 years ago

  • Is duplicate of Bug #4179: Invalid value for field 'resource.networkInterfaces[0].accessConfigs[0].natIP': 'false'. Must be an IP address added
Actions #6

Updated by Kavita Gaikwad over 5 years ago

  • Status changed from New to Duplicate
Actions

Also available in: Atom PDF