Project

General

Profile

Bug #14881

[foreman-debug] collect /etc/qpid-dispatch/qdrouterd.conf

Added by Bryan Kearney about 3 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Category:
foreman-debug
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1331307
Description of problem:
qdrouterd plays important role in katello communication between Satellite and Capsule / Content Hosts. In case its config is malformed (or e.g. lacks some option after failing upgrade), various issues can occur that are hard to be identified without the config file.

Please collect /etc/qpid-dispatch/qdrouterd.conf

Version-Release number of selected component (if applicable):
katello-debug-3.0.0-3.el7sat.noarch

How reproducible:
100%

Steps to Reproduce:
1. foreman-debug
2. Unpack it
3. Check if /etc/qpid-dispatch/qdrouterd.conf is present

Actual results:
No /etc/qpid-dispatch/qdrouterd.conf collected.

Expected results:
/etc/qpid-dispatch/qdrouterd.conf to be collected

Additional info:
Proposing patch:

--- /usr/share/foreman/script/foreman-debug.d/katello-debug.sh 2016-04-01 17:19:17.000000000 0200
+
+ /usr/share/foreman/script/foreman-debug.d/katello-debug.sh.new 2016-04-28 11:05:07.863000000 +0200
@ -55,6 +55,9 @ fi
add_cmd "qpid-stat --ssl-certificate=/etc/pki/katello/qpid_client_striped.crt -b amqps://localhost:5671 -q" "qpid_stat_queues"
add_cmd "qpid-stat --ssl-certificate=/etc/pki/katello/qpid_client_striped.crt -b amqps://localhost:5671 -u" "qpid_stat_subscriptions"

# Qpid dispatch router (*)
+add_files /etc/qpid-dispatch/qdrouterd.conf
# Gofer
add_files /etc/gofer
add_files /var/log/gofer

(in longer term, there should be "if [ $NOGENERIC -eq 0 ]; then" clause but until sosreport collects the file in downstream (matter of 1-2 years, due to [1]), I suggest collecting it every time in foreman-debug)

[1] https://github.com/sosreport/sos/issues/623

Associated revisions

Revision b73086c2 (diff)
Added by Bryan Kearney about 3 years ago

Fixes #14881 - Add in /etc/qpid-dispatch/qdrouterd.conf for files which are collected (#215)

History

#1 Updated by The Foreman Bot about 3 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello-packaging/pull/215 added

#2 Updated by Eric Helms about 3 years ago

  • Legacy Backlogs Release (now unused) set to 143

#3 Updated by Bryan Kearney about 3 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF