Project

General

Profile

Bug #15471

Foreman Fails to load Smart-Proxy PuppetCA page

Added by Chris Pisano over 4 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
PuppetCA
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

When navigating to the PuppetCA Smart-Proxy and going to the PuppetCA tab Foreman fails to load the page throwing an argument error. Debug logs from the Foreman production.log is attached as well as a screenshot of the webUI. All other functions of the PuppetCA Smart-Proxy seem to be working as expected.

http://pasteboard.co/1Pl9rITX.png
http://pastebin.com/pfj0C6dg

Associated revisions

Revision 20fb338e (diff)
Added by Tomer Brisker over 4 years ago

Fixes #15471 - Find CA expiry even if some dates are missing

If some certificates in the puppet CA proxy are missing dates, the proxy
view for puppet CA will be broken as the comparison used to find the CA
certficate's expiry date will fail. This change also adds a minor
optimization - running in O(n) instead of O(nlogn).

Revision db5d6c48 (diff)
Added by Tomer Brisker over 4 years ago

Fixes #15471 - Find CA expiry even if some dates are missing

If some certificates in the puppet CA proxy are missing dates, the proxy
view for puppet CA will be broken as the comparison used to find the CA
certficate's expiry date will fail. This change also adds a minor
optimization - running in O(n) instead of O(nlogn).

(cherry picked from commit 20fb338ed84d7c024c9a00d96cd4509bcc2d84f8)

History

#1 Updated by The Foreman Bot over 4 years ago

  • Status changed from New to Ready For Testing
  • Assignee set to Tomer Brisker
  • Pull request https://github.com/theforeman/foreman/pull/3605 added

#2 Updated by Tomer Brisker over 4 years ago

The root cause for this is that you have a certificate missing the "valid from" field on your CA proxy - you might be interested in looking into that.
In any case, I've created a patch that prevents this failure (see linked PR).

#3 Updated by Chris Pisano over 4 years ago

Tomer Brisker wrote:

The root cause for this is that you have a certificate missing the "valid from" field on your CA proxy - you might be interested in looking into that.
In any case, I've created a patch that prevents this failure (see linked PR).

Thank you for this! I was banging my head against the wall yesterday. I'll test out this patch in my lab after I'm finished going through my production certs and clearing things up.

#4 Updated by Anonymous over 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#5 Updated by Dominic Cleal over 4 years ago

  • Legacy Backlogs Release (now unused) set to 161

Also available in: Atom PDF