Project

General

Profile

Feature #1557

Add more information for static ip configuration

Added by Andreas Rogge over 10 years ago. Updated over 10 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

To make it easier to deploy a host with static ip configuration foreman should know
1. wether the host uses dhcp or not
2. the default router for the host's subnet
3. the nameserver the host should use

Information should be available in templates as @host.gateway and @host.nameserver (or maybe @host.nameserver1 and @host.nameserver2).

The information wether DHCP is to be used or not should be configurable on a host level. If absent it should default to "yes" if the host's subnet has a DHCP smart-proxy, "no" otherwise.
The information for the default router should be configurable per subnet
The information for the nameserver should be configurable per subnet (I'm not really sure this is a good idea, but usually a nameserver is either reachable from a subnet or not so per-subnet seems reasonable)


Related issues

Is duplicate of Foreman - Feature #1361: Allow subnet information to be accessed from provisioning templates & add gateway, dns to subnetsClosed2011-11-28

History

#1 Updated by Ohad Levy over 10 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF