Project

General

Profile

Bug #15579

Not able to select/publish " Use Latest Version" of puppet module in content view

Added by Partha Aji over 2 years ago. Updated 9 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Content Views
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1351728
Description of problem:

While adding puppet module in content view, even when we select the "latest version" and publish the content view , the older version of puppet module is published. Which can be checked under file "/etc/puppet/environments/ENVNAME/modules/MODULE/metadata.json"

Version-Release number of selected component (if applicable):
Red Hat Satellite 6.2 Beta

How reproducible:

Steps to Reproduce:
1.Add a Puppet Module with multiple Versions
2.Choose " Use Latest"
3.Publish the Content-View and look into /etc/puppet/environments/ENVNAME/modules/MODULE/metadata.json - > Oldest Version is published, not the latest version.

Actual results:
It is not able to select the latest version and publish it

Expected results:
It is should be able to select the latest version and publish it

Additional info:

Associated revisions

Revision 57eaec9b (diff)
Added by David Davis over 2 years ago

Fixes #15579 - Fix how we order puppet modules (#6164)

When we converted puppet modules from being stored in elasticsearch to
the database, we stopped ordering by sortable_version. Instead we used
id and version in different places. Id doesn't work for obvious reasons
but we can't order by versions because when string sorting say 1.9 and
1.12, we get back 1.9 first in desc order when we really need 1.12. This
reintroduces sortable_version.

History

#1 Updated by The Foreman Bot over 2 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/6164 added

#2 Updated by Anonymous over 2 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#3 Updated by Justin Sherrill over 2 years ago

  • Subject changed from Satellite 6.2: Not able to select/publish " Use Latest Version" of puppet module in content view to Not able to select/publish " Use Latest Version" of puppet module in content view
  • Legacy Backlogs Release (now unused) set to 171

#4 Updated by Eric Helms over 2 years ago

  • Legacy Backlogs Release (now unused) changed from 171 to 162

Also available in: Atom PDF