Project

General

Profile

Bug #15745

Capsule sync failed while syncing ostree contents

Added by John Mitsch almost 3 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Foreman Proxy Content
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1323644
Description of problem: I was trying to sync contents from Satellite server to external capsule and sync failed as below:

~]# hammer -u admin -p changeme capsule content synchronize --id 2
[...................................................................... ] [50%]
400 Bad Request
400 Bad Request
400 Bad Request
400 Bad Request
400 Bad Request
400 Bad Request
404 Resource Not Found
404 Resource Not Found
404 Resource Not Found
404 Resource Not Found
404 Resource Not Found
404 Resource Not Found

Later, I checked the /var/log/messages on external capsule and found following exception:

Apr 4 06:16:35 cloud-qe-7 pulp: pulp.server.webservices.middleware.exception:INFO: Missing resource(s): repository=Default_Organization-Dev-cv_ostree-Red_Hat_Enterprise_Linux_Atomic_Host-Red_Hat_Enterprise_Linux_Atomic_Host_Trees
Apr 4 06:16:36 cloud-qe-7 pulp: pulp.server.controllers.repository:ERROR: (31428-88416) Exception adding importer to repo [Default_Organization-Dev-custom_ostree-ostree-f23_ostree]; the repo will be deleted
Apr 4 06:16:36 cloud-qe-7 pulp: pulp.server.controllers.repository:ERROR: (31428-88416) Traceback (most recent call last):
Apr 4 06:16:36 cloud-qe-7 pulp: pulp.server.controllers.repository:ERROR: (31428-88416) File "/usr/lib/python2.7/site-packages/pulp/server/controllers/repository.py", line 410, in create_repo
Apr 4 06:16:36 cloud-qe-7 pulp: pulp.server.controllers.repository:ERROR: (31428-88416) importer_controller.set_importer(repo_id, importer_type_id, importer_repo_plugin_config)
Apr 4 06:16:36 cloud-qe-7 pulp: pulp.server.controllers.repository:ERROR: (31428-88416) File "/usr/lib/python2.7/site-packages/celery/local.py", line 167, in <lambda>
Apr 4 06:16:36 cloud-qe-7 pulp: pulp.server.controllers.repository:ERROR: (31428-88416) call = lambda x, *a, **kw: x._get_current_object()(*a, **kw)
Apr 4 06:16:36 cloud-qe-7 pulp: pulp.server.controllers.repository:ERROR: (31428-88416) File "/usr/lib/python2.7/site-packages/pulp/server/async/tasks.py", line 473, in call
Apr 4 06:16:36 cloud-qe-7 pulp: pulp.server.controllers.repository:ERROR: (31428-88416) return super(Task, self).__call__(*args, **kwargs)
Apr 4 06:16:36 cloud-qe-7 pulp: pulp.server.controllers.repository:ERROR: (31428-88416) File "/usr/lib/python2.7/site-packages/pulp/server/async/tasks.py", line 103, in call
Apr 4 06:16:36 cloud-qe-7 pulp: pulp.server.controllers.repository:ERROR: (31428-88416) return super(PulpTask, self).__call__(*args, **kwargs)
Apr 4 06:16:36 cloud-qe-7 pulp: pulp.server.controllers.repository:ERROR: (31428-88416) File "/usr/lib/python2.7/site-packages/celery/app/task.py", line 420, in call
Apr 4 06:16:36 cloud-qe-7 pulp: pulp.server.controllers.repository:ERROR: (31428-88416) return self.run(*args, **kwargs)
Apr 4 06:16:36 cloud-qe-7 pulp: pulp.server.controllers.repository:ERROR: (31428-88416) File "/usr/lib/python2.7/site-packages/pulp/server/controllers/importer.py", line 72, in set_importer
Apr 4 06:16:36 cloud-qe-7 pulp: pulp.server.controllers.repository:ERROR: (31428-88416) validate_importer_config(repo.repo_id, importer_type_id, repo_plugin_config)
Apr 4 06:16:36 cloud-qe-7 pulp: pulp.server.controllers.repository:ERROR: (31428-88416) File "/usr/lib/python2.7/site-packages/pulp/server/controllers/importer.py", line 144, in validate_importer_config
Apr 4 06:16:36 cloud-qe-7 pulp: pulp.server.controllers.repository:ERROR: (31428-88416) importer_type_id=importer_type_id)
Apr 4 06:16:36 cloud-qe-7 pulp: pulp.server.controllers.repository:ERROR: (31428-88416) PulpCodedValidationException: The importer type ostree_web_importer does not exist

Looks like sync failed while syncing ostree contents to capsule and that's because of missing installed plugin: pulp-ostree-plugins

I installed pulp-ostree-plugin on capsule and later ran installer as below:

[root@cloud-qe-7 ~]# foreman-installer --scenario capsule --enable-ostree true
Installing Done [100%] [..................................................................]
Success!
The full log is at /var/log/foreman-installer/capsule.log

But still I'm getting:

Apr 4 06:26:51 cloud-qe-7 pulp: pulp.server.controllers.repository:ERROR: (31427-95712) PulpCodedValidationException: The importer type ostree_web_importer does not exist
Apr 4 06:26:51 cloud-qe-7 pulp: pulp.server.webservices.middleware.exception:INFO: The importer type ostree_web_importer does not exist
Apr 4 06:26:51 cloud-qe-7 pulp: pulp.server.controllers.repository:ERROR: (31427-92576) Exception adding distributor to repo [Default_Organization-Dev-cv_rhel7-RHEL7-RHEL7_x86_64]; the repo will be deleted
Apr 4 06:26:51 cloud-qe-7 pulp: pulp.server.controllers.repository:ERROR: (31427-92576) Traceback (most recent call last):
Apr 4 06:26:51 cloud-qe-7 pulp: pulp.server.controllers.repository:ERROR: (31427-92576) File "/usr/lib/python2.7/site-packages/pulp/server/controllers/repository.py", line 425, in create_repo
Apr 4 06:26:51 cloud-qe-7 pulp: pulp.server.controllers.repository:ERROR: (31427-92576) dist_controller.add_distributor(repo_id, type_id, plugin_config, auto_publish, dist_id)
Apr 4 06:26:51 cloud-qe-7 pulp: pulp.server.controllers.repository:ERROR: (31427-92576) File "/usr/lib/python2.7/site-packages/pulp/server/controllers/distributor.py", line 50, in add_distributor
Apr 4 06:26:51 cloud-qe-7 pulp: pulp.server.controllers.repository:ERROR: (31427-92576) raise exceptions.InvalidValue(['distributor_type_id'])
Apr 4 06:26:51 cloud-qe-7 pulp: pulp.server.controllers.repository:ERROR: (31427-92576) InvalidValue: Invalid properties: ['distributor_type_id']
Apr 4 06:26:51 cloud-qe-7 pulp: pulp.server.webservices.middleware.exception:INFO: Invalid properties: ['distributor_type_id']
Apr 4 06:26:51 cloud-qe-7 pulp: pulp.server.controllers.repository:ERROR: (31428-81120) Exception adding importer to repo [Default_Organization-Dev-custom_ostree-ostree-f23_ostree]; the repo will be deleted
Apr 4 06:26:51 cloud-qe-7 pulp: pulp.server.controllers.repository:ERROR: (31428-81120) Traceback (most recent call last):
Apr 4 06:26:51 cloud-qe-7 pulp: pulp.server.controllers.repository:ERROR: (31428-81120) File "/usr/lib/python2.7/site-packages/pulp/server/controllers/repository.py", line 410, in create_repo
Apr 4 06:26:51 cloud-qe-7 pulp: pulp.server.controllers.repository:ERROR: (31428-81120) importer_controller.set_importer(repo_id, importer_type_id, importer_repo_plugin_config)
Apr 4 06:26:51 cloud-qe-7 pulp: pulp.server.controllers.repository:ERROR: (31428-81120) File "/usr/lib/python2.7/site-packages/celery/local.py", line 167, in <lambda>
Apr 4 06:26:51 cloud-qe-7 pulp: pulp.server.controllers.repository:ERROR: (31428-81120) call = lambda x, *a, **kw: x._get_current_object()(*a, **kw)
Apr 4 06:26:51 cloud-qe-7 pulp: pulp.server.controllers.repository:ERROR: (31428-81120) File "/usr/lib/python2.7/site-packages/pulp/server/async/tasks.py", line 473, in call
Apr 4 06:26:51 cloud-qe-7 pulp: pulp.server.controllers.repository:ERROR: (31428-81120) return super(Task, self).__call__(*args, **kwargs)
Apr 4 06:26:51 cloud-qe-7 pulp: pulp.server.controllers.repository:ERROR: (31428-81120) File "/usr/lib/python2.7/site-packages/pulp/server/async/tasks.py", line 103, in call
Apr 4 06:26:51 cloud-qe-7 pulp: pulp.server.controllers.repository:ERROR: (31428-81120) return super(PulpTask, self).__call__(*args, **kwargs)
Apr 4 06:26:51 cloud-qe-7 pulp: pulp.server.controllers.repository:ERROR: (31428-81120) File "/usr/lib/python2.7/site-packages/celery/app/task.py", line 420, in call
Apr 4 06:26:51 cloud-qe-7 pulp: pulp.server.controllers.repository:ERROR: (31428-81120) return self.run(*args, **kwargs)
Apr 4 06:26:51 cloud-qe-7 pulp: pulp.server.controllers.repository:ERROR: (31428-81120) File "/usr/lib/python2.7/site-packages/pulp/server/controllers/importer.py", line 72, in set_importer
Apr 4 06:26:51 cloud-qe-7 pulp: pulp.server.controllers.repository:ERROR: (31428-81120) validate_importer_config(repo.repo_id, importer_type_id, repo_plugin_config)
Apr 4 06:26:51 cloud-qe-7 pulp: pulp.server.controllers.repository:ERROR: (31428-81120) File "/usr/lib/python2.7/site-packages/pulp/server/controllers/importer.py", line 144, in validate_importer_config
Apr 4 06:26:51 cloud-qe-7 pulp: pulp.server.controllers.repository:ERROR: (31428-81120) importer_type_id=importer_type_id)
Apr 4 06:26:51 cloud-qe-7 pulp: pulp.server.controllers.repository:ERROR: (31428-81120) PulpCodedValidationException: The importer type ostree_web_importer does not exist

Version-Release number of selected component (if applicable):
Satellite 6.2 beta snap6

How reproducible:
always

Steps to Reproduce:
1. Install satellite server, sync ostree contents
2. promote/publish them to dev env
3. sync contents to external capsule

Actual results:

sync failed:

(31428-81120) PulpCodedValidationException: The importer type ostree_web_importer does not exist

Expected results:
sync should succeed.

Additional info:

Associated revisions

Revision 7361916f (diff)
Added by John Mitsch almost 3 years ago

Fixes #15745 - Ostree feed url is incorrect for capsules

Revision 9ef374ff
Added by Partha Aji almost 3 years ago

Merge pull request #6193 from johnpmitsch/ostree-feed-url

Fixes #15745 - Ostree feed url is incorrect for capsules

History

#1 Updated by The Foreman Bot almost 3 years ago

  • Status changed from New to Ready For Testing
  • Assignee set to John Mitsch
  • Pull request https://github.com/Katello/katello/pull/6193 added

#2 Updated by John Mitsch almost 3 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#3 Updated by Justin Sherrill almost 3 years ago

  • Legacy Backlogs Release (now unused) set to 143

Also available in: Atom PDF