Project

General

Profile

Bug #16163

selecting vmware cluster shows a continuous spinner

Added by Ondřej Pražák almost 4 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Normal
Category:
Compute resources - VMware
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1338964
Description of problem:

Selecting the vmware cluster throws a traceback
2016-05-23 14:18:15 [app] [W] Action failed
 | NoMethodError: undefined method `summary' for #<RbVmomi::VIM::Folder:0x007fe1f2510208>
 | /opt/theforeman/tfm/root/usr/share/gems/gems/fog-vsphere-0.6.3/lib/fog/vsphere/requests/compute/list_clusters.rb:35:in `cluster_attributes'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/fog-vsphere-0.6.3/lib/fog/vsphere/requests/compute/get_cluster.rb:8:in `get_cluster'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/fog-vsphere-0.6.3/lib/fog/vsphere/models/compute/clusters.rb:17:in `get'
 | /usr/share/foreman/app/models/compute_resources/foreman/model/vmware.rb:53:in `cluster'
 | /usr/share/foreman/app/models/compute_resources/foreman/model/vmware.rb:101:in `resource_pools'
 | /usr/share/foreman/app/models/compute_resources/foreman/model/vmware.rb:122:in `available_resource_pools'
 | /usr/share/foreman/app/controllers/compute_resources_controller.rb:116:in `resource_pools'
 | /opt/rh/rh-ror41/root/usr/share/gems/gems/actionpack-4.1.5/lib/action_controller/metal/implicit_render.rb:4:in `send_action'
Version-Release number of selected component (if applicable):
sat62-snap12.1
How reproducible:
Steps to Reproduce:
1. Add vmware compute resource
2. while creating a "new host"
3. populate the cluster under the "virtual machine" tab
Actual results:
| NoMethodError: undefined method `summary' for #<RbVmomi::VIM::Folder:0x007fe1f2510208>
Also the spinner is seen continuously at the top most locatio near to "Red Hat Satellite".
as seen in /var/log/foreman/production.log
Expected results:
No traceback and no continuous spinner should be seen while provisioning.
Note: The NoMethodError issue seems to be already resolved,
but spinner does not seem to disapper when it should.

Associated revisions

Revision 105917c2 (diff)
Added by Ondřej Pražák almost 4 years ago

Fixes #16163 - Hide spinner for vmware cluster

History

#1 Updated by Ondřej Pražák almost 4 years ago

  • Subject changed from selecting vmware cluster shows a continuous spinner and throws a traceback to selecting vmware cluster shows a continuous spinner and throws a traceback
  • Target version set to 115

#2 Updated by Ondřej Pražák almost 4 years ago

  • Subject changed from selecting vmware cluster shows a continuous spinner and throws a traceback to selecting vmware cluster shows a continuous spinner

#3 Updated by Marek Hulán almost 4 years ago

  • Target version changed from 115 to 1.6.0

#4 Updated by The Foreman Bot almost 4 years ago

  • Status changed from New to Ready For Testing
  • Assignee set to Ondřej Pražák
  • Pull request https://github.com/theforeman/foreman/pull/3760 added

#5 Updated by Ondřej Pražák almost 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#6 Updated by Marek Hulán almost 4 years ago

  • Legacy Backlogs Release (now unused) set to 160

Also available in: Atom PDF