Project

General

Profile

Bug #16343

Containers hosted on Atomic host not able to access Katello yum repos

Added by Partha Aji over 2 years ago. Updated 7 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Atomic
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1364436
Description of problem:

Issue came up during testing of Satellite 6.2 features.
Atomic host is able to pull ostree updates from satellite 6.2 without any issues.
When you start a container in the atomic host and then try to install any package inside the container, then the package installation fails with the following message
[root@9d01b5384636 /]# yum install httpd
Loaded plugins: ovl, product-id, search-disabled-repos, subscription-manager
https://XXXX/pulp/ostree/web/XXXX/Library/content/dist/rhel/server/7/7Server/x86_64/os/repodata/repomd.xml: [Errno 14] HTTPS Error 404 - Not Found
Trying other mirror.
If I register a RHEL 7 host to the same satellite 6.2, then I can install or build containers
This seems to arise due to way how ostree repo is enabled
rhsm.conf of the host
baseurl= https://XXXX/pulp/ostree/web/
Version-Release number of selected component (if applicable):
Atomic Host 7.2.6
How reproducible:
Always
Steps to Reproduce:
1. Satellite 6.2
2. register atomic host to Satellite 6.2
3. start a rhel7 docker container
4. try to install a package in the container
Actual results:
package installation inside the docker container fails with a 404 message
Expected results
Docker containers should be able to access Satellite repos with respect to the host entitlement

Associated revisions

Revision b5b9b748 (diff)
Added by Partha Aji over 2 years ago

Fixes #16343 - Redirect fix for Atomic Hosts (#158)

Rhel 7 Docker Containers inside an Atomic host need to be able to pull
rpms from within /pulp/ostree/web/. But those are available only under
/pulp/repos

This commit sets up a config to redirect 'yum repo like' calls to
/pulp/repos to facilitate that

History

#1 Updated by Partha Aji over 2 years ago

  • Subject changed from Containers hosted on Atomic host not able to access Satellite 6.2 yum repos to Containers hosted on Atomic host not able to access Satellite 6.2 yum repos
  • Category set to Atomic

#2 Updated by Partha Aji over 2 years ago

  • Subject changed from Containers hosted on Atomic host not able to access Satellite 6.2 yum repos to Containers hosted on Atomic host not able to access Katello yum repos

#3 Updated by Partha Aji over 2 years ago

  • Pull request https://github.com/Katello/puppet-pulp/pull/158 added

#4 Updated by Partha Aji over 2 years ago

  • Status changed from New to Closed

#5 Updated by Justin Sherrill over 2 years ago

  • Legacy Backlogs Release (now unused) set to 162

Also available in: Atom PDF