Project

General

Profile

Actions

Bug #171

closed

Error when adding parameters to a new "Host Group"

Added by Marcello de Sousa over 14 years ago. Updated about 14 years ago.

Status:
Closed
Priority:
Low
Assignee:
Category:
Web Interface
Target version:
Difficulty:
Triaged:
Fixed in Releases:
Found in Releases:

Description

Not a big deal but, when I create a new "Host Group" ("Puppet Group" menu item in the settings), if I immediatelly try to add parameters I get an error. Example:

2 errors prohibited this hostgroup from being saved
There were problems with the following fields:
    * Group parameters is invalid
    * Group parameters is invalid

Workaround: First create the group without any parameters and click CREATE. Then re-open it for editing and only then add/create the parameters.


Related issues 1 (0 open1 closed)

Is duplicate of Foreman - Refactor #200: Remove activescaffold from the puppet groups pageClosedOhad Levy04/07/2010Actions
Actions #1

Updated by Marcello de Sousa over 14 years ago

Btw, on the parameter field I see the following error:

1 error prohibited this groupparameter from being saved
There were problems with the following fields:
    * Hostgroup can't be blank
Actions #2

Updated by Ohad Levy over 14 years ago

  • Target version deleted (0.1-4)

I know.

The whole edit page of hosts classes etc is undergoing a change now (in the NO_AS branch), this will also fix this issue.

Actions #3

Updated by Ohad Levy over 14 years ago

  • Target version set to 0.1-5
Actions #4

Updated by Paul Kelly over 14 years ago

  • Status changed from New to Ready For Testing
  • Assignee changed from Ohad Levy to Paul Kelly

A fix for this bug can be found on branch bug/171 on my github

Actions #5

Updated by Ohad Levy about 14 years ago

  • Status changed from Ready For Testing to Closed
Actions

Also available in: Atom PDF