Project

General

Profile

Bug #17363

Links to Subscriptions from activation key are broken

Added by Martin Bacovsky over 5 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Normal
Category:
Activation Key
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1395723

Description of problem:
hyperlink of the susbcription from the activation keys -> subscriptions page doesn't work. It appears to be missing an id in the URL that need sot be present.

Version-Release number of selected component (if applicable):
  1. rpm -q satellite
    satellite-6.2.4-1.0.el7sat.noarch

How reproducible:
Always

Steps to Reproduce:
1. Install Satellite 6.2.4
2. Go to https://satellite/activation_keys/XXX/add-subscriptions
(replace XXX with a valid activation key ID)
3. Attempt to click on the title of one of the Subscriptions

Actual results:
You'll observe that the subscription name hyperlinks to "https://satellite/subscriptions//info" (note the double-/ character - between the should be a subscription ID).

Expected results:
Hyperlinks contain subscription ids

Additional info:

Associated revisions

Revision 7a1fe184 (diff)
Added by Brad Buckingham over 5 years ago

fixes #17363 - fix links to subscriptions on activation key

This commit fixes the issue where the links to subscriptions
from the activation keys page were not working properly.

It does change the link to be on the 'Consumed' column content
versus the subscription name, since there could be multiple
pools for a given subscription.

History

#1 Updated by Justin Sherrill over 5 years ago

  • Subject changed from Links to Subscriptions from activation key are broken to Links to Subscriptions from activation key are broken
  • Legacy Backlogs Release (now unused) set to 114

#2 Updated by Brad Buckingham over 5 years ago

  • Status changed from New to Assigned
  • Assignee changed from Eric Helms to Brad Buckingham

#3 Updated by The Foreman Bot over 5 years ago

  • Status changed from Assigned to Ready For Testing
  • Legacy Backlogs Release (now unused) deleted (114)
  • Pull request https://github.com/Katello/katello/pull/6466 added

#4 Updated by Brad Buckingham over 5 years ago

  • Target version set to 140

#5 Updated by Brad Buckingham over 5 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#6 Updated by Eric Helms over 5 years ago

  • Legacy Backlogs Release (now unused) set to 208

Also available in: Atom PDF