Project

General

Profile

Bug #1803

"private method `chomp' called for nil:NilClass" error while clicking on "Clone" host

Added by Rami Vaknin about 7 years ago. Updated about 7 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Version:
RPM installation of foreman-1.0.0-1.el6.noarch on RHEL 6.3

Scenario:
Click on "Clone" in the right-hand button next to an existing host.

Error:
private method `chomp' called for nil:NilClass

Full Trace:
NoMethodError
private method `chomp' called for nil:NilClass
app/models/host.rb:178:in `shortname'
app/helpers/hosts_helper.rb:150:in `name_field'
app/views/hosts/_form.html.erb:27:in `_app_views_hosts__form_html_erb__2094191793_69921894522640_1048030'
app/helpers/layout_helper.rb:147:in `form_for'
app/views/hosts/_form.html.erb:4:in `_app_views_hosts__form_html_erb__2094191793_69921894522640_1048030'
app/views/hosts/new.html.erb:3:in `_app_views_hosts_new_html_erb__1344605706_69921894536820_0'
app/controllers/hosts_controller.rb:82:in `clone'


Related issues

Is duplicate of Foreman - Bug #1781: clone host can failClosed2012-07-26

History

#1 Updated by Ohad Levy about 7 years ago

  • Status changed from New to Duplicate
  • Priority changed from High to Normal

Also available in: Atom PDF