Project

General

Profile

Bug #1887

Postgres error creating new host when selecting hostgroup and environment

Added by Andreas Ntaflos almost 10 years ago. Updated almost 10 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Database
Target version:
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Since updating Foreman to develop/75bd351e4217fe04f583642799dbb3f028f0fbcc creating a new host triggers an internal error (500) when selecting the hostgroup and thus the environment (production). Here are debug logs from the event: http://pastie.org/4909049. Attached is also a screenshot just for orientation and reference.

Using PostgreSQL 9.1 on Ubuntu 12.04.1.

foreman-new-host-pgsql-error.png View foreman-new-host-pgsql-error.png 53.1 KB Screenshot of "new host" interface Andreas Ntaflos, 10/04/2012 11:08 AM
Foreman new host pgsql error

Associated revisions

Revision 4e493ad7 (diff)
Added by Joseph Magen almost 10 years ago

removed lower() on default_scope to get tests to pass in postgresql

fixes #1887
fixes #1839

History

#2 Updated by Joseph Magen almost 10 years ago

  • Status changed from New to Resolved

This is caused by lower() on the default_scope.

- default_scope :order => 'lower(puppetclasses.name)'
+ default_scope :order => 'puppetclasses.name'

has been committed

#3 Updated by Ohad Levy almost 10 years ago

  • Category set to Database
  • Assignee set to Joseph Magen
  • Target version set to 1.1

Also available in: Atom PDF