Project

General

Profile

Feature #19098

Add a warning and override requirement for installations with default partition schemes

Added by Stephen Benjamin over 2 years ago. Updated over 1 year ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
Installer
Target version:
Difficulty:
easy
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1435421

Description of problem:

Currently, we do not have a way to prevent a user of Satellite 6 from filling up their partitions with database or pulp data, and we do not enforce explicit partitioning schemes to help prevent issues with bleed-over of over-syncing causing a user to fill up a partition which results in database corruption.

Proposal is to implement a a override-able warning into the installer that prevents initial run of the installer when items for postgres, mongo, and pulp are all found to be under the same partition with no division (i.e. /var).

Version-Release number of selected component (if applicable):
All

How reproducible:
100%

Steps to Reproduce:
1. You can install with any partition scheme.
2. You can fill up /var with data from pulp and corrupt your database content.

Actual results:
Caseload resulting from unknowingly breaking Satellite due to space issues

Expected results:
We should warn users of a best practice scenario and make them acknowledge that they are at risk for corrupting their data because of a non-divided partitioning scheme.

Additional info:
Related to RHBZ 1435420

History

#1 Updated by Stephen Benjamin over 2 years ago

  • Subject changed from Add a warning and override requirement for installations with default partition schemes to Add a warning and override requirement for installations with default partition schemes
  • Legacy Backlogs Release (now unused) set to 114

#2 Updated by Chris Roberts over 2 years ago

  • Assignee set to Chris Roberts
  • Difficulty set to easy

#3 Updated by Chris Roberts about 2 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF