Project

General

Profile

Bug #19190

Hidden --puppet-dir foreman-installer option when using katello

Added by Florent Peterschmitt about 5 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Normal
Category:
Installer
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Hello,

I want to use a custom path for puppet configuration, ssl dirs and so.

One way to do that with foreman-installer alone (without katello), is with the --puppet-dir /etc/<customdir> parameter.

When using Katello, this parameter is gone and forcing it's usage makes the installer complaining: unknown parameter.

Also all parameters for puppet are gone.


Related issues

Is duplicate of Katello - Refactor #17714: Move puppet to top level of the installerClosed2016-12-16

History

#1 Updated by John Mitsch about 5 years ago

Florent,

What katello version are you seeing this on?

#2 Updated by John Mitsch about 5 years ago

  • Tracker changed from Support to Bug
  • Status changed from New to Need more information

#3 Updated by Sophian Mehboub about 5 years ago

John Mitsch wrote:

Florent,

What katello version are you seeing this on?

Hello John,

I work with Florent
We use katello-3.3.1-1

#4 Updated by John Mitsch about 5 years ago

  • Category set to Installer
  • Assignee set to Stephen Benjamin

#5 Updated by John Mitsch about 5 years ago

  • Legacy Backlogs Release (now unused) set to 228

#6 Updated by Stephen Benjamin about 5 years ago

  • Status changed from Need more information to Resolved

Puppet options are already in 3.4.

Output of foreman-installer --full-help:

= Module puppet:
    --puppet-additional-settings  A hash of additional main settings. (current: {})
    --puppet-auth-template        Use a custom template for the auth
                                  configuration. (current: "puppet/auth.conf.erb")
    --puppet-autosign             If set to a boolean, autosign is enabled or disabled
                                  for all incoming requests. Otherwise this has to be
                                  set to the full file path of an autosign.conf file or
                                  an autosign script. If this is set to a script, make
                                  sure that script considers the content of autosign.conf
                                  as otherwise Foreman functionality might be broken. (current: "/etc/puppetlabs/puppet/autosign.conf")
    --puppet-autosign-content     If set, write the autosign file content
                                  using the value of this parameter.
                                  Cannot be used at the same time as autosign_entries
                                  For example, could be a string, or
                                  file('another_module/autosign.sh') or
                                  template('another_module/autosign.sh.erb') (current: UNDEF)
    --puppet-autosign-entries     A list of certnames or domain name globs
                                  whose certificate requests will automatically be signed.
                                  Defaults to an empty Array. (current: [])
    --puppet-autosign-mode        mode of the autosign file/script (current: "0664")
    --puppet-autosign-source      If set, use this as the source for the autosign file,
                                  instead of autosign_content. (current: UNDEF)
    --puppet-ca-crl-filepath      Path to CA CRL file, dynamically resolves based on
                                  $::server_ca status. (current: UNDEF)
    --puppet-ca-port              Puppet CA port (current: UNDEF)
    --puppet-ca-server            Use a different ca server. Should be either
                                  a string with the location of the ca_server
                                  or 'false'. (current: UNDEF)
    --puppet-classfile            The file in which puppet agent stores a list
                                  of the classes associated with the retrieved
                                  configuration. (current: "$statedir/classes.txt")
    --puppet-codedir              Override the puppet code directory. (current: "/etc/puppetlabs/code")
    --puppet-configtimeout        How long the client should wait for the
                                  configuration to be retrieved before
                                  considering it a failure. (current: UNDEF)
    --puppet-cron-cmd             Specify command to launch when runmode is
                                  set 'cron'. (current: UNDEF)
    --puppet-dir                  Override the puppet directory. (current: "/etc/puppetlabs/puppet")
    --puppet-dns-alt-names        Use additional DNS names when generating a
                                  certificate.  Defaults to an empty Array. (current: [])
    --puppet-group                Override the name of the puppet group. (current: "puppet")
    --puppet-hiera-config         The hiera configuration file. (current: "$confdir/hiera.yaml")
    --puppet-listen               Should the puppet agent listen for connections. (current: false)
    --puppet-listen-to            An array of servers allowed to initiate a puppet run.
                                  If $listen = true one of three things will happen:
                                  1) if $listen_to is not empty then this array
                                  will be used.
                                  2) if $listen_to is empty and $puppetmaster is
                                  defined then only $puppetmaster will be
                                  allowed.
                                  3) if $puppetmaster is not defined or empty,
                                  $fqdn will be used. (current: [])
    --puppet-logdir               Override the log directory. (current: "/var/log/puppetlabs/puppet")
    --puppet-main-template        Use a custom template for the main puppet
                                  configuration. (current: "puppet/puppet.conf.erb")
    --puppet-manage-packages      Should this module install packages or not.
                                  Can also install only server packages with value
                                  of 'server' or only agent packages with 'agent'. (current: true)
    --puppet-module-repository    Use a different puppet module repository (current: UNDEF)
    --puppet-package-provider     The provider used to install the agent.
                                  Defaults to chocolatey on Windows
                                  Defaults to undef elsewhere (current: UNDEF)
    --puppet-package-source       The location of the file to be used by the
                                  agent's package resource.
                                  Defaults to undef. If 'windows' or 'msi' are
                                  used as the provider then this setting is
                                  required. (current: UNDEF)
    --puppet-pluginfactsource     URL to retrieve Puppet facts from during pluginsync (current: "puppet:///pluginfacts")
    --puppet-pluginsource         URL to retrieve Puppet plugins from during pluginsync (current: "puppet:///plugins")
    --puppet-pluginsync           Enable pluginsync. (current: true)
    --puppet-port                 Override the port of the master we connect to. (current: 8140)
    --puppet-rundir               Override the PID directory. (current: "/var/run/puppetlabs")
    --puppet-runinterval          Set up the interval (in seconds) to run
                                  the puppet agent. (current: 1800)
    --puppet-runmode              Select the mode to setup the puppet agent. (current: "service")
    --puppet-sharedir             Override the system data directory. (current: "/opt/puppetlabs/puppet")
    --puppet-show-diff            Show and report changed files with diff output (current: false)
    --puppet-splay                Switch to enable a random amount of time
                                  to sleep before each run. (current: false)
    --puppet-splaylimit           The maximum time to delay before runs.
                                  Defaults to being the same as the run interval.
                                  This setting can be a time interval in seconds
                                  (30 or 30s), minutes (30m), hours (6h), days (2d),
                                  or years (5y). (current: "1800")
    --puppet-srv-domain           Search domain for SRV records (current: "example.com")
    --puppet-ssldir               Override where SSL certificates are kept. (current: "/etc/puppetlabs/puppet/ssl")
    --puppet-syslogfacility       Facility name to use when logging to syslog (current: UNDEF)
    --puppet-systemd-cmd          Specify command to launch when runmode is
                                  set 'systemd.timer'. (current: UNDEF)
    --puppet-unavailable-runmodes  Runmodes that are not available for the
                                  current system. This module will not try
                                  to disable these modes. Default is []
                                  on Linux, ['cron', 'systemd.timer'] on
                                  Windows and ['systemd.timer'] on other
                                  systems. (current: [])
    --puppet-use-srv-records      Whether DNS SRV records will be used to resolve
                                  the Puppet master (current: false)
    --puppet-usecacheonfailure    Switch to enable use of cached catalog on
                                  failure of run. (current: true)
    --puppet-user                 Override the name of the puppet user. (current: "puppet")
    --puppet-vardir               Override the puppet var directory. (current: "/opt/puppetlabs/puppet/cache")
    --puppet-version              Specify a specific version of a package to
                                  install. The version should be the exact
                                  match for your distro.
                                  You can also use certain values like 'latest'. (current: "present")

#7 Updated by Stephen Benjamin about 5 years ago

  • Is duplicate of Refactor #17714: Move puppet to top level of the installer added

#8 Updated by Stephen Benjamin about 5 years ago

  • Status changed from Resolved to Duplicate

Also available in: Atom PDF