Project

General

Profile

Actions

Feature #20743

closed

Select certain fields for output

Added by Josh Pavel over 6 years ago. Updated over 6 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Hammer core
Target version:
-
Difficulty:
Triaged:
Team Backlog:
Fixed in Releases:
Found in Releases:
In Kanboard:

Description

The --include field is not very clear; I intended to use it as follows:

host list --hostgroup "foo" --include "Owner"

I expected that to generate a list of hosts in the hostgroup "foo" and add an extra field for "Owner", alongside ID, Name, Operating System, Host Group, IP, MAC, Content View, and Lifecycle Environment.

We require the ability to generate reports of the data in Foreman; e.g., HW info, Owner, IP, OS for audit reasons.


Related issues 1 (0 open1 closed)

Is duplicate of Hammer CLI - Feature #19135: Possibility to limit or add fields that are displayedClosedOleh FedorenkoActions
Actions #1

Updated by Tomáš Strachota over 6 years ago

  • Category set to Hammer core
  • Status changed from New to Duplicate

Thanks for reporting the issue. The same feature has been requested in http://projects.theforeman.org/issues/19135 Please comment there if you have some additional input. I'm closing this one as duplicate.

At the moment the --include parameter in host list has no effect and it should be removed until we implement the correct way of limiting/extending output.
I reported the issue here: http://projects.theforeman.org/issues/20754

Actions #2

Updated by Tomáš Strachota over 6 years ago

  • Is duplicate of Feature #19135: Possibility to limit or add fields that are displayed added
Actions

Also available in: Atom PDF