Project

General

Profile

Bug #20982

Reboot required - Katello Agent

Added by Sven Vogel over 3 years ago. Updated over 2 years ago.

Status:
Duplicate
Priority:
Normal
Category:
Hosts
Target version:
Difficulty:
medium
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Hi,

i use CentOS 7.4.1708 and after rollout i get reboot required. i rebooted the host but nothing happens. there is no service under content host -> traces

There are any issues known or changes to centos 7.4?

Katello Agent 3.0.2
Katello 3.4.2
Foreman 1.5.4 -- tried also 1.5.3

how can we debug this?

thanks

Sven

traces.PNG View traces.PNG 13.2 KB Sven Vogel, 09/18/2017 10:18 AM
host_info.PNG View host_info.PNG 8.03 KB Sven Vogel, 09/18/2017 10:18 AM
Traces Host info

Related issues

Related to Katello - Bug #20703: Content Hosts Traces page doesnt workClosed2017-08-23

History

#1 Updated by Anonymous over 3 years ago

  • Project changed from Foreman to Katello
  • Category deleted (Host creation)

#2 Updated by Justin Sherrill over 3 years ago

  • Category set to Hosts
  • Assignee set to Justin Sherrill

This is likely a duplicate of http://projects.theforeman.org/issues/20703 where the host traces list is empty, but in reality the server threw an error. Can you check the /var/log/foreman/production.log for errors when you visit that page?

#3 Updated by Justin Sherrill over 3 years ago

  • Related to Bug #20703: Content Hosts Traces page doesnt work added

#4 Updated by Klaas D over 3 years ago

https://github.com/FrostyX/tracer/issues/92
I think this is in tracer not katello, fixed in next tracer release

#5 Updated by Sven Vogel over 3 years ago

i found the following in production.log (debug mode) content host -> traces

2017-09-21 11:05:10 487af2e4 [app] [I] Completed 500 Internal Server Error in 31ms (Views: 0.5ms | ActiveRecord: 4.4ms)
2017-09-21 11:05:10 487af2e4 [app] [D] With body: {"displayMessage":"undefined method `order' for #\u003cArray:0x007ff407d529f8\u003e","errors":["undefined method `order' for #\u003cArray:0x007ff407d529f8\u003e"]}
 |
2017-09-21 11:05:10 844a53a1 [app] [I]   Rendered api/v2/errors/not_found.json.rabl within api/v2/layouts/error_layout (1.6ms)
2017-09-21 11:05:10 844a53a1 [app] [I] Completed 404 Not Found in 44ms (Views: 25.0ms | ActiveRecord: 2.9ms)
2017-09-21 11:05:10 ff0f0f3c [app] [I] Started GET "/api/v2/bookmarks?search=controller%3Dundefined" for 172.16.1.12 at 2017-09-21 11:05:10 +0200
2017-09-21 11:05:10 ff0f0f3c [app] [I] Processing by Api::V2::BookmarksController#index as JSON
2017-09-21 11:05:10 ff0f0f3c [app] [I]   Parameters: {"search"=>"controller=undefined", "apiv"=>"v2"}
2017-09-21 11:05:10 ff0f0f3c [app] [I] Current user: admin (administrator)
2017-09-21 11:05:10 ff0f0f3c [app] [D] Setting current user thread-local variable to admin
2017-09-21 11:05:10 ff0f0f3c [app] [I]   Rendered api/v2/bookmarks/index.json.rabl within api/v2/layouts/index_layout (2.5ms)
2017-09-21 11:05:10 ff0f0f3c [app] [D] Body: {
 |   "total": 21,
 |   "subtotal": 0,
 |   "page": 1,
 |   "per_page": 20,
 |   "search": "controller=undefined",
 |   "sort": {
 |     "by": null,
 |     "order": null
 |   },
 |   "results": []
 | }
 |

does this help?

thanks

Sven

#6 Updated by Sven Vogel over 3 years ago

2017-09-21 11:11:17 106b57f0 [app] [I] Processing by Api::V2::HostsController#show as JSON
2017-09-21 11:11:17 106b57f0 [app] [I]   Parameters: {"page"=>"1", "paged"=>"true", "per_page"=>"20", "search"=>"", "sort_by"=>"updated", "sort_order"=>"DESC", "apiv"=>"v2", "id"=>"traces"}
2017-09-21 11:11:17 106b57f0 [app] [I] Current user: admin (administrator)
2017-09-21 11:11:17 106b57f0 [app] [D] Setting current user thread-local variable to admin
2017-09-21 11:11:17 106b57f0 [app] [I] Couldn't find Host::Managed with 'id'=traces [WHERE "hosts"."type" IN ('Host::Managed')] (ActiveRecord::RecordNotFound)
2017-09-21 11:11:17 106b57f0 [app] [I]   Rendered api/v2/errors/not_found.json.rabl within api/v2/layouts/error_layout (1.6ms)
2017-09-21 11:11:17 106b57f0 [app] [I] Completed 404 Not Found in 24ms (Views: 6.6ms | ActiveRecord: 3.2ms)
2017-09-21 11:11:17 ade3443f [app] [I] Started GET "/common/views/registration.html" for 172.16.1.12 at 2017-09-21 11:11:17 +0200
2017-09-21 11:11:17 ed0c8a8a [app] [I] Started GET "/api/v2/hosts/15/traces?search=" for 172.16.1.12 at 2017-09-21 11:11:17 +0200
2017-09-21 11:11:17 ed0c8a8a [app] [I] Processing by Katello::Api::V2::HostTracerController#index as JSON
2017-09-21 11:11:17 ed0c8a8a [app] [I]   Parameters: {"search"=>"", "api_version"=>"v2", "host_id"=>"15"}
2017-09-21 11:11:17 ed0c8a8a [app] [I] Current user: admin (administrator)
2017-09-21 11:11:17 ed0c8a8a [app] [D] Setting current user thread-local variable to admin
2017-09-21 11:11:17 ed0c8a8a [app] [E] NoMethodError: undefined method `order' for #<Array:0x007ff3fd9aaeb8>

#7 Updated by Klaas D over 3 years ago

so this is a duplicate of #20703 / #20885 I'd guess :)

#8 Updated by Sven Vogel over 3 years ago

should we close it and redirect to the duplicates?

#9 Updated by Justin Sherrill over 3 years ago

  • Status changed from New to Duplicate

#10 Updated by Justin Sherrill over 3 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF