Project

General

Profile

Bug #21582

Installing Katello plugin breaks api v1

Added by Timo Goebel about 2 years ago. Updated 3 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
API
Target version:
Difficulty:
easy
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Installing Katello in an existing Foreman install, breaks the way the APIv1 results look:

Query:
curl https://foreman.example.com/api/v1/hosts

Without Katello:
[{"host":{"name":"host.example.com","id":23294,"hostgroup_id":null,"operatingsystem_id":45}}]

With Katello:
[{"name":"host.example.com","id":23294,"hostgroup_id":null,"operatingsystem_id":45}]

This is really bad. Installing a plugin should never, ever change the way the API results look.

The root cause for this is:
https://github.com/Katello/katello/blob/6aca54157e579d6312a9e4a49609df0ffa1685b1/config/initializers/rabl_init.rb#L13-L18

History

#1 Updated by Eric Helms about 2 years ago

  • Legacy Backlogs Release (now unused) set to 114

#2 Updated by Eric Helms about 2 years ago

  • Difficulty set to easy

#3 Updated by Jonathon Turel 3 months ago

  • Target version changed from Katello Backlog to Katello Recycle Bin
  • Status changed from New to Rejected

V1 API is no more

Also available in: Atom PDF